Toad World® Forums

TDP 3.7 Automatic Aliasing

I tried the auto-alias feature in code completion, and it doesn’t seem to be working. I type my select statement, select * from [table], and no alias appears. I have the feature checked in the alias options menu. Is there something I am missing? I am connecting to a sql server database.

That feature is not turned on by default. You need to turn it on in the options.

I did all that and it still doesn’t create aliases like it does in the samples.

It works for me. I checked Oracle and SQL Server. Try these exact steps. This is how I am testing.

  1. In a SQL Editor, type "select "

  2. Wait for the table drop down and then choose a table.

  3. With this option enabled you will get the table, an alias and the word FROM inserted. Also, the cursor will move and the columns will be listed with the alias in from of the column name.

Ok, I got it now. Thanks. I didn’t realize that you could only type “select” before being prompted to select a table. It worked for me now.