TDP graphic on all attached sql files

Toad Data Point 5.7 is doing a very annoying thing: whenever I attach a .sql file in an email, the .sql file shows in Outlook with the Toad imagery, even though it may be a query from SQL Server, Teradata, Oracle, whatever. So it's annoying, and also confuses the user because we mostly use TDP for one specific database, I may be sending a query to be run in SQL Server. I know this must be in preferences somewhere, but I can't find it.

I'm willing to bet this has more to do with your (or the recipients') Windows settings than it does with TDP. Specifically, it appears that Windows has associated files of type .SQL with the TDP application. This could have happened if the installing user checked the SQL File box to associate TDP to files with this extension at some point in the installation wizard.


Try changing in Windows the app associated with the .SQL file type. Right-click on any SQL file on your file system and select the Open With-> Choose Another App dialog. You should be able to choose the app of your choice and make it the default that Windows uses to open your SQL files.
Hope this helps.

1 Like