Toad World® Forums

Team Coding and VCS control, mismatch when "checked out" a Trigger!


#1

Hi everyone!

This time I have encountered a problem with VCS.

I’m working with a SqlNav 5.5.x versione (Xpert Edition) and Microsoft Visual Source Safe 6.0 - (oracle client and server version 9.2.x).

When I “checked out” a trigger that exist in VSS repository,
(or execute “Compare to VCS” command)
I get this message (see attachs):
The database version of this object differs from the latest VCS revision.

But the difference is only in the first line
vcs version:
CREATE OR REPLACE SCHEMA.TRIGGER_NAMEdatabase version
CREATE OR REPLACE TRIGGER_NAME
Help me !

P.S.
In prefererence setting I’ve tried to check/unckeck the option:
“prefix with schema name” (section Extract DDL), but VCS version doesn’t change.

Other objects aren’t affected from this problem.

vcs.jpeg


#2

Hi Cristian,

Thanks for your feedback. Could you please try the following to see if it resolves your issue:

  1. As the user SQLNAV (or whoever has been granted the team coding admin role), go to your Team Coding Settings screen (accessible from Preference -> Team Coding -> VCS Provider Options, or from the “Settings” button in the Team coding Status dialog)

  2. Go to the General tab and check the “Use Trigger Description for DDL” option(see attachment) and click OK.

Let us know if you still have the same issue after doing the above, thanks.

regards,

Bernard
connecting settings.jpeg


#3

Hi Bernard,

This morning I tried to check/unckeck the option, but results didn’t change
(i have deleted vcs version, then i’ve checked out/modified/checked in a trigger)

Other suggestions ?

Thanks
Cristian


#4

Hi Cristian,

Thanks for getting back to me. This is strange as I am not able to reproduce your issue when I have the option checked. Could you clarify the following:

  1. If you have the “Use Trigger Description for DDL” checked before adding a new trigger to the VCS, do you still get a mismatch when you try to check it out (while keeping the option checked).

  2. Was your “Update Databse After Check-In” option checked all the time while experiencing this issue? If not, could you check it and keep it checked all the time (eg. while adding a new object to vcs, checking out an object).

  3. Were you checking out an object in the schema that you were logged on to, or from another schema (via the “All Schemas” node in the DB Nav tree)?

  4. Can you try selecting “SCC: Microsoft visual SourceSafe” as your version control provider and see if you still encounter the issue (please keep the two options specified above checked). Note that it’s advisable to create a new code control group (CCG) for the purpose of this test.

Thanks !

regards,
Bernard