Toad World® Forums

Temp file deleted before passing to external program?

Howdy,

In 13.3.0.63, I'm generating a Datapump export. If I use the "notepad" icon to preview the parameter file, the external editor says that the file doesn't exist.

This works in 13.2 GA, and I recall seeing something about temp files now being immediately deleted....seems like it would be impossible for Toad to know if this particular temp file was done being used though.

Thoughts?

Thanks!
Rich

Hi Rich,

Yup, it's due to the temp file change. The weird thing is that I definitely remember testing that.

I'll check it out, thanks.

-John

Do you have an external editor set up in options? (if not, we default to notepad)

Hmmm...I have been using EmEditor for my external editor, but even when I switch it back to Windows Nutpad (is that the right name?), I still get the same error.

Could just be me. I have the Milorganite Touch today (everything I touch turns to..."natural fertilizer").

Thanks John!
Rich

I guess it's a timing issue. I'll have it delete the files when the datapump window closes.

1 Like