Test "clientless" WITH a Client Present

Is there some way that I could test the clientless feature while having a client installed? I want to test that feature, but I cannot uninstall the client to do so.

I especially want to test the SSL capability.


Yes. You will smack yourself for not seeing it. You can only check/uncheck it when there are no connections active. I use this feature when I want to have simultaneous connections to different database versions that would normally require 2 different clients.

Yeah, but that is subdued in mine.


It is disabled if you have a connection active.

Disconnect all, then uncheck it, then connect.
Start Toad. Don't make any connections. Uncheck it. Then connect.

For a non-SSH route, it works fine with TCPS as the protocol.

We just have to specify the path to the Oracle Wallet which is normally specified in sqlnet.ora. I like the fact that no special configs are required for this.

I assume it is on purpose that clientless+ssl does not work via an SSH tunnel. I get the following:

NET: Cannot connect to server on host 'LOCALHOST': No connection could be made because the target machine actively refused it. Socket Error Code: 10061($274D)

Also, Is there some way to specify a wallet globally. All of our many connections use the same wallet.


No-client mode can find your sqlnet.ora and tnsnames.ora if you have a TNS_ADMIN environment
variable. There you can configure the wallet as you normally would in either/both files.

I'm not sure I tried SSL+SSH. That never occurred to me. I'll log it and see if it can be added.

OK Great!

It did find my sqlnet.ora and tnsnames.ora just fine, and the connection went through with SSL and without using the client. Wonderful.

I then setup for a clientless, non-SSL (ANO) connection via SSH, and that was successful. After that, I switched it to SSL. This involved changing the protocol to "tcps" in the TNS Names file and switching the port in the SSH settings. A connection attempt with that configuration returns "NET: Connection refused".


When a client is used, Toad doesn't have to do anything special for TCPS because Oracle client handles that.

In no-client mode, we rely on those 3rd party components I mentioned to support TCPS. Those same components support SSH, but the configuration is different for each case. And because I didn't consider using both, well, I'm not surprised it doesn't work. I don't know if using both on one connection is possible.

But - you may be able to fake it. I'll bet if you configure a SSH connection to a particular DB, and also configure a SSL connection (which requires SSH, but don't try to configure it for both)....then you can probably get the SSL connection to work by making the SSH connection first. Maybe that's kinda pointless and hacky but it would probably work.

Well, I tried that but it did not work. The same connection refused message is returned. It would have been a hack, though.

I have noticed this: Apparently, using clientless has the effect of only reading the TNS Names file once when TOAD first starts. Any changes I make to the file do not show up after hitting F5 or even after closing the connection window and reopening it. I have to completely exit TOAD and reopen it. Is that how it is supposed to work?

Also, when making a connection clientless, a successful connection does not always get added to the displayed list of previous connections. But, it seems that it gets added to the list but does not appear in it. When I went to manually create a single connection with the create new button when the connection I was creating was not present in the list, on saving the new connection, it complained that it was already in the list. But, it wasn't in the displayed list of previous connections. When I said yes to "update" the entry anyway, then it popped in.

I think the list had been corrupted somehow because when it was not appearing, opening the connection window would show multiple random entries selected. These were connections I had not made in a while. The most recent one, sorted descending by Last Connect, would be the last one made with the client earlier today. The clientless connection was simply not there until I "added" it by "updating" it.

Have I stumbled onto a bug, or is there some extra "English" that I need to put on the ball?


The tnsnames.ora not reloading problem sounds like a bug.

Re: connection not getting added - is the grid filtered somehow? that's what it sounds like.

I am not sure how I would filter the list except by "Show favorites only" and I don't use that. It is unchecked. If you mean right-click->Filter Data, there is no filter defined there.

I also do not have any grouping set.

I confirmed that the desired entry was not in the list by ordering the list by name and seeing that one was not there where it would have been. After creating it and being told it was there and "updating" it, it showed up where it hadn't before.

If you previously made the connection using a client, and had the "show selected home only" box checked, that might have done it. I am just shooting from the hip here.

That box isn't visible in no-client mode.

My brain is about toast for the day, but I can try to reproduce this tomorrow.

Whoa doggy! That was it. I had that box checked, but of course it is not displayed when "Connect using Oracle Client" is not checked. Apparently it is still enforced when "clientless".

awesome. That will make my day easier tomorrow.

1 Like