Toad v.16 connect with no client doesn't work

In the new connection windows , the checkbox connect using oracle client is checked and can't be unchecked.

You can't check it or uncheck it when a connection is already made.

The best way to switch it is:

Turn off autoconnect.
Restart Toad
Uncheck the box
Make your connections (turn autoconnect back on if you want)
The setting will be remembered after that.

How do you Turn off autoconnect?

Just uncheck here, if any are checked.

What client is Toad using when connecting with no oracle client?

In this case, no oracle client is used. Toad is communicating with the Oracle server directly.

What driver is Toad using to connect directly?

We are not using any driver. This functionality is built into Toad.