Toad World® Forums

Toad 10.6.1, slow typing in the editor and cancelling script running issues


#1

I’ve done a search of the Quest support knowledge base, here and google, but no luck.

I installed v10.6.1 today, as the 10.0.0.41 version I was using previously had a (fairly infrequent, eg. once a week/fortnight) tendency to hang if you looked at it the wrong way, or reran a query involving xmltype columns after you’d just cancelled it.

Since intalling the latest version, I’ve already had to restart it a dozen times, mainly because of extremely poor typing response times in the editor, but also due to access violations because I dared to stop a script from running.

Has anyone else come across the editor becoming slower to respond? It seems to be related to the number of tabs I have open, as well as having at least one file open (and I wouldn’t call a ~1000 line, 34kb file a large file).

I’ve tried taking the syntax highlighting off, and the insight stuff off, but nothing seems to help.

To give you an idea, I typed 48 characters fairly quickly, and it took over 10 seconds before my typing appeared on the screen, once I’d stopped typing.

Is there any other setting I might have missed? I might have to switch back to v10.0.0.41 at this rate *{:frowning:


#2

I do not think it’s Toad. I was having the same problem (9.1) a few seconds
ago… I also had the slow typing response in my email. I went to task
manager/ processes and something in internet explorer was eating up the CPU
time… I closed them one by one till I found the offending one. It was my
email (GMAIL).

Since I restarted it the problem went away.

On Tue, Feb 8, 2011 at 11:29 AM, Boneist wrote:

Message from: Boneist

I’ve done a search of the Quest support knowledge base, here and google,
but no luck.

I installed v10.6.1 today, as the 10.0.0.41 version I was using previously
had a (fairly infrequent, eg. once a week/fortnight) tendency to hang if you
looked at it the wrong way, or reran a query involving xmltype columns after
you’d just cancelled it.

Since intalling the latest version, I've already had to restart it a
dozen times, mainly because of extremely poor typing response times in the
editor, but also due to access violations because I dared to stop a script
from running.

Has anyone else come across the editor becoming slower to respond? It seems
to be related to the number of tabs I have open, as well as having at least
one file open (and I wouldn't call a ~1000 line, 34kb file a large
file).

I've tried taking the syntax highlighting off, and the insight stuff
off, but nothing seems to help.

To give you an idea, I typed 48 characters fairly quickly, and it took over
10 seconds before my typing appeared on the screen, once I'd stopped
typing.

Is there any other setting I might have missed? I might have to switch back
to v10.0.0.41 at this rate *{:-(

Historical Messages

Author: Boneist
Date: Tue Feb 08 09:29:56 PST 2011

I’ve done a search of the Quest support knowledge base, here and google,
but no luck.

I installed v10.6.1 today, as the 10.0.0.41 version I was using previously
had a (fairly infrequent, eg. once a week/fortnight) tendency to hang if you
looked at it the wrong way, or reran a query involving xmltype columns after
you’d just cancelled it.

Since intalling the latest version, I've already had to restart it a
dozen times, mainly because of extremely poor typing response times in the
editor, but also due to access violations because I dared to stop a script
from running.

Has anyone else come across the editor becoming slower to respond? It seems
to be related to the number of tabs I have open, as well as having at least
one file open (and I wouldn't call a ~1000 line, 34kb file a large
file).

I've tried taking the syntax highlighting off, and the insight stuff
off, but nothing seems to help.

To give you an idea, I typed 48 characters fairly quickly, and it took over
10 seconds before my typing appeared on the screen, once I'd stopped
typing.

Is there any other setting I might have missed? I might have to switch back
to v10.0.0.41 at this rate *{:-(

__
_______________________________________


#3

also due to access violations

Please send your Toad.elf file to the list. It should contain a log of
exceptions encountered which is essential to fixing them unless you have a
reproducible process that I can follow. Also your support bundle may be useful.

to be related to the number of tabs I have open

Performance has been improved when many tabs are open for Toad 11. Toad 10.6
should be on par with 10.5 and earlier as far as memory and resource consumption
are concerned, but there are likely some differences under different
circumstances. How many tabs do you have open? If you have a couple dozen then
you are pushing the limits. Toad 11 should be able to handle that just fine. For
instance I just opened 83 files in 1 Editor instance in Toad 11 and CPU usage is
0%.

as well as having at least one file open

Are you noticing this with any particular file or can it be any file? A case was
recently resolved where a file would hang Toad. This was evident by looking at
Task Manager and 1 CPU core was pegged to 100%. Does Task Manager reveal
elevated CPU usage when Toad should be idle?

Is there any other setting I might have missed?

I would check on Code Insight options. View|Options|Editor|Code Assist. You can
try disabling the Available Identifiers and Expected Tokens options in the “Toad
Insight Objects” list as well as looking at the “Delay pop-ups” setting. If that
setting is very low (100, 200, etc. milliseconds) and you are typing such that
the time between keystrokes exceeds that setting then the code insight process
is cranking away and consuming resources. You can also disable the option “Check
syntax as you type” if it is enabled.

Other than that try Gene’s suggestion of a restart if your PC has been up for
days. Many time I’ve seen error logs revealing that Toad has been up for days or
that the PC has been up for over a week. I find this very surprising as every
machine I’ve ever had runs like crap after 3 days or so and requires a restart.

Michael


#4

Nothing else is going slowly, though, just my Toad.

I can see a noticable degradation in the time it takes my typing to display the more tabs I open on the editor, especially if one contains a file.

My typing is showing up instantly in this window, yet when I type in my toad, it’s taking several seconds to display my typing.

I’m beginning to feel a bit like Tony Blair, in … that … I’m … typing … with … pauses … after … each … word … now!

It’s becoming unworkable for me *{:frowning:


#5

How many tabs are you talking about having open at one time? I am often in TOAD
with up to 20 tabs open, almost all of which are files. These are even often
split between different editors, sometimes up to 20 in multiple editors at the
same time. . .

In the previous version of TOAD I noticed some issues, but not at all as severe
as you describe here. In the beta, things work beautifully and I haven’t
had any issues for a long time now. . .


#6

Thanks Michael; I’m going to start by restarting my machine (16 days uptime!), but since it’s home time, I’ll have to look at the rest of your suggestions tomorrow.

I was able to reproduce it (open 10-12 tabs, then open a file, typing slows way down). My popup timer thingy is set to 2000ms and I type a lot faster than 2 seconds between every letter (~60wpm in fact)!

I find it strange that a couple of dozen tabs open would be pushing it, given that my v10.0.0.41 coped with that without any problems, albeit spread across different editors and connections.

Guess I’ll see tomorrow if the pc restart sorts it! (crosses fingers)


#7

If not and you can use the beta try that out. I think that you’ll noticed
improved performance all around.


#8

Michael Staszewski wrote:

Performance has been improved when many tabs are open for Toad 11. Toad 10.6
should be on par with 10.5 and earlier as far as memory and resource consumption
are concerned, but there are likely some differences under different
circumstances.

I see 10.6 as significantly worse than 10.0 in terms of the number of tabs I can have open before a slowdown occurs; I would frequently have multiple tabs, open files etc without any typing slowdown, and with long up-times of both my machine and Toad itself.

How many tabs do you have open? If you have a couple dozen then
you are pushing the limits. Toad 11 should be able to handle that just fine. For
instance I just opened 83 files in 1 Editor instance in Toad 11 and CPU usage is
0%.

I’ve just reproduced the issue by opening 10 tabs in the same editor window, typing a line in each tab and then opening a file.

I’ve also opened 5 small files and 6 tabs interspersed with each other, and the degradation is noticable after the 5th file is opened.

All the files I’ve been using have been on a network drive.

Are you noticing this with any particular file or can it be any file? A case was
recently resolved where a file would hang Toad. This was evident by looking at
Task Manager and 1 CPU core was pegged to 100%. Does Task Manager reveal
elevated CPU usage when Toad should be idle?

When I’m typing, Toad sits at around 45% CPU usage (I have 2 cores, I believe), but as soon as I stop typing, it drops back to 0.

I would check on Code Insight options. View|Options|Editor|Code Assist. You can
try disabling the Available Identifiers and Expected Tokens options in the “Toad
Insight Objects” list as well as looking at the “Delay pop-ups” setting. If that
setting is very low (100, 200, etc. milliseconds) and you are typing such that
the time between keystrokes exceeds that setting then the code insight process
is cranking away and consuming resources. You can also disable the option “Check
syntax as you type” if it is enabled.

The above tests were done with the following Toad Insight settings:

  • Enable Code Insight pick list ticked
  • Cache Code Insight results ticked
  • Sort pick list alphabetically ticked
  • Check syntax as you type unticked
  • Available Variables/Parameters & Expected Tokens unticked

#9

it’s worth noting that when I’ve closed all the editors, the slowness persists when I open a new editor and start typing, forcing me to close and restart Toad.