Toad World® Forums

Toad 10.6 all data in chinese

i just installed Toad 10.6 and i got all my DBs to show in the DB browser but when i go in the schema browser all my tables and the data inside is all in chinese, how can change it to english

Really – ALL of it? Or just some of it?

I’m wondering how afraid I should be to mention the word
‘corruption’.

What version of Toad did you upgrade from?

What do you see when you display the same data using SQL*plus?

Daniel B Madvig
Computer Technologies

Northwestern College & Northwestern Media
3003 Snelling Ave.
St. Paul, MN 55113
www.nwc.edu

651.631.5323
image001.jpeg

Really - ALL of it? Or just some of it?

I’m wondering how afraid I should be to mention the word
‘corruption’.

What version of Toad did you upgrade from?
I’m thinking that it may not be Chinese, but maybe it’s Unicode and the font can’t cope?

Like those “squares with numbers in” you see in Firefox under similar conditions?

Just a thought.

Cheers,
Norm. [TeamT]

Norman Dunbar
Contract Senior Oracle DBA
Capgemini Database Build Team
Internal : 7 28 2051
External : 0113 231 2051

Information in this message may be confidential and may be legally privileged. If you have received this message by mistake, please notify the sender immediately, delete it and do not copy it to anyone else.

We have checked this email and its attachments for viruses. But you should still check any attachment before opening it.
We may have to make this message and any reply to it public if asked to under the Freedom of Information Act, Data Protection Act or for litigation. Email messages and attachments sent to or from any Environment Agency address may also be accessed by someone other than the sender or recipient, for business purposes.

If we have sent you information and you wish to use it please read our terms and conditions which you can get by calling us on 08708 506 506. Find out more about the Environment Agency at www.environment-agency.gov.uk

it was a fresh install, i was using 6.. on another pc but on this on its a fresh install

Some good info to help you get this figured out

http://www.toadworld.com/Blogs/tabid/67/EntryId/598/Identifying-the-Source-of-Pot
ential-Unicode-Issues-in-Toad%C2%AE-for-Oracle.aspx

well i found the support bundle and i want to change the NLS_LANG to the default but i cant figure out how to change it

On your pc/client?

Make sure you set it to match your local environment, not the database’s.

Then try using REGEDIT

yeah on my client, my whole client is set to my location correctly but when i check the NLS_LANG its set to SPANISH_SPAIN.WE8ISO8859P1, i dont know if it should say mexico in order to work

well i found the support bundle and i want to change the NLS_LANG to the
default but i cant figure out how to change it

There is no “default” for NLS_LANG and the Support Bundle only shows the values
for the Homes, it’s the Toad Advisor which makes recommendations for NLS_LANG to
those who already have a deep understanding of what it means, and it points out
a mismatch between the local char set and what the Oracle OCI would typically be
expecting.

If you don’t know how to set that, and you’re seeking answers here…raises
concerns to me. You can’t just flip that about here and there and see what
happens. There are serious ramifications to changing that. If you set it wrong,
and continue to post data to your database, you could start sending corrupt data
to your database without being aware of it. Then you have a mish-mash of good
data, bad data, who knows what.

And if it was wrong and that was your problem before, as I suspect the case may
be, then you can’t fix it by changing NLS_LANG. You may have to do some serious
database maintenance to try to fix the data which was posted wrong.

Unless you’re just playing around with a local, junk database, you want to get
assistance from your DBA.

well in that case ill stick with the working toad 6 and leave this for another time, since playing around with federal DBs isnt such a bright idea, thanks for the insight

Miguel,

Advance warning: do not mess with valuable databases, data and NLS_LANG.
Read everything below before even thinking of changing anything! :wink:

yeah on my client, my whole client is set to my location correctly but
Do you mean in Control Panel -> Regional Settings when you say “the
whole client”?

when i check the NLS_LANG its set to SPANISH_SPAIN.WE8ISO8859P1, i dont
know if it should say mexico in order to work
I should imaging that it might possibly be “MEXICAN
SPANISH_MEXICO.???” where there is a space between Mexican and
Spanish in the language portion.

Of course, the character set might be something other than WE8ISO8859P1

  • it depens. You may need to consult the Globalization manual in the
    Oracle docs for advice.

As Mark points out, if you get it wrong, you stand the risk of
corrupting your data - so best get a test database to play in before you
make any changes, just in case.

By the way, what does “SELECT DUMP(some_column, 16) FROM table_name
WHERE …” give you for the hex codes? Do they look correct for the
character set you should be using? I’m not sure what character set you
should be usingin Mexico, WE8ISO8859P1 might, note might, be correct as
that covers Spanish_Spain - I assume Spanish and Mexican Spanish don’t
have different characters?

If you cannot get a database to play in, ask for a schema in the one you
are having problems with, and copy a table that you know gives you grief
and Chinese characters.

HTH


Cheers,
Norm. [TeamT]

The problem is your Oracle Client… To be safe, make sure your Oracle client is at least the same version and patch level as your database…