Toad World® Forums

Toad 10.6 and TFS 2010 error

Hi all,

I’ve a problem with Toad 10.6 and TFS 2010:

I correctly configured Toad and I added procedures, packages, views, functions to TFS 2010. If I try to check out an object Toad works well.

If I try to login on my PC with another domain user or if I use Toad in an another PC with a differents domain user I receive this erros:

Unable to get revision from VCS repository .

All users have same permission on TFS and PC where Toad is installed.

Help me pls !!!

Regards.

Thank you very much !!!

Did you ever find out the reason for this error?? Did you solve the issue?

Mario,

I probably need more information to track this one down. Since you said you are
working with Packages, Procedures etc . I am assuming you are using Team Coding
and not the File Based Source Control.

It sounds like your Team Coding settings are correct, otherwise nothing would
work when you are logged in as yourself. I’d like you to test something.

When logged in as a different user, try launching the Version Control Browser
from the Team Coding toolbar. If you are logging on correctly to TFS, you should
be able to navigate the default project. If not you will either get an error
message that you are not logged in correctly (unlikely) or you may be able to
see the Project but not be able to navigate it.

Stephen

Mario,

One more thing … the revision history message usually gives the last error
generated. The message should be something like this ‘Unable to get
revision from VCS repository. The system cannot find the file specified.’
Do you get any additional information in the error message?

Thanks

Stephen

Stephen,

I responded to this issue because i have been facing the same problem…Let me describe the issue…

We were able to set up team coding with team foundation server 2010…
under team coding->team coding status, we have all checked…

We have a schema(lets call it abc)…there is a code control group with the same name in that schema…whose object mask includes everything in that schema…
We have several developers who log into the same schema…we have all the objects successfully uploaded to the vcs repository. Developer 1 who was working with it could check out and check in logging in as schema abc.

However while i was trying to check out by logging in as abc schema from my machine , i get an error

Unable to get revision from vcs repository…error downloading “the filename”…
with the filename referring to the object that i was trying to check out.

and in the bottom of the toad output window window i get a message

“Error:VCS archive is empty”

I already have a toad workspace defined and a local folder mapped…

what else am i missing???

I think we can re-create that scenario here … and see what happens…

Thanks

Stephen

“Error:VCS archive is empty”

Paint me naïve because I’ve never worked with the Toad hooks into any
versioning repository :slight_smile:

Question:

What’s the possibility that the original dev created the file locally as
opposed to on the host repository so the host is actually empty? Or in the
alternative, that the file did get synced with the host and you’re
querying the local folder?

Perhaps you have access to an alternative tool so you can browse both the local
and host folders and find out just where the files got created and where they
don’t exist. That may offer a clue as to what’s occurring.

Roger S.

If you haven’t already read this article or seen the accompanying video,
please take a look. It may help you.

http://toadworld.com/BLOGS/tabid/67/EntryId/649/Configuring-Toad®-Team-Codin
g-to-use-Microsoft-Team-Foundation-Server-2010.aspx

Regards.

John
image002.jpeg

If you haven’t already read this article or seen the accompanying video,
please take a look. It may help you.

http://toadworld.com/BLOGS/tabid/67/EntryId/649/Configuring-Toad®-Team-Codin
g-to-use-Microsoft-Team-Foundation-Server-2010.aspx

Regards.

John
image001.jpeg

Thanks for your input…Yes, i have already checked out the video as well as the pdf document…As i said before, toad interaction with TFS works for the first developer…if another OS user logs into the same schema and tries to check out, that is when we are having the issue…

Roger,
Seems like all files are in the host…and i seem to definitely accessing the correct host…
The way i confirm is, i created another code control group and tried to upload/download from the vcs repository and it seems to have worked well…

Well… off-hand then, I’d suggest taking a look at the permissions
that are being set on the files/folders on the host. Someone must be responsible
for administering the host, so they should be able to help with this part.

Here’s a possible test, if you haven’t done it already: using your
network account, log in to the original person’s desktop and see if you
run into the same issue. I’ve been assuming that by “another OS
user” you mean “another user from their own computer”.

Not knowing TFS, the speculation is: perhaps the file permissions are being
defaulted to being set for the particular computer that created the files.

Roger S.

Roger thanks for the suggestions . We have been able to re-create here and I
think may have narrowed it down … I’ll give an update as soon as I can
confirm …

Stephen

Any update on this Stephen???

Thanks.