Toad World® Forums

Toad 12.5.1.1 How to turn on 'choose primary key' option when generating merge statement


#1

Hi all,

Recently I switch to Toad 12.5.1.1,

before this I use Toad 11, usually when I want to generate merge statement using Toad, I just click the Export dataset button in the Data Grid and choose Export format: Merge Statement.

Usually after i click OK (if there’s no primary key defined), it will prompt me to choose Primary keys for my table.

However, now Toad (12.5.1.1) didnt prompt me for the primary key after I click OK & directly generate the merge statement.

merge_statement_error.png

Then the generated merge statement become like this (snippet , in bold):

ON (A."" = B."")
WHEN NOT MATCHED THEN
INSERT (

I’m not sure whether this is related to Toad version or some setting is turned off,

if it’s a setting can anyone help to illuminate me on which setting should I change?

Thanks in advance.


#2

It’s a bug. It should always prompt when there is no primary key. It should never do this business. I have fixed it for the next beta.


#3

I just upgraded to 12.6.0.53 and I’m still seeing the same results.

ON (A."" = B."")


#4

12.6 came out before I fixed it. It is fixed in the current 12.7 beta.