Toad World® Forums

Toad 12.5 Open / Save Dialog not showing Favorites

Favorite folders are not displayed in the Editor File Open / Save Dialog box. I double checked my Toad Options to confirm I have favorites, and the entries are in there. Is there something I have to do to make this work?

In the screenshot below, 12.1 is on the left, and 12.5 is on the right. 12.1 has the Favorites, 12.5 is not showing them.

Thanks in advance!

The new Open/Save dialog in Toad 12.1 and above support renaming favorites, whereas the old style dialog doesn’t. For Toad 12.5 and above, we've defaulted to use the old-style dialog, unless you imported your user settings from a prior version. It's possible something may have gotten out of sync on your user settings.

First, check the drop-down itself to make sure your favorite folders aren't appearing in the drop-down list. A favorites folder isn't selected by default in that drop-down box. If it isn't appearing, double-check your options to make sure it's appearing here:

If you'd prefer, you can also check to make sure it's appearing in the new style dialog, by selecting the "Toad World" Script Repository option here:

You don't have to use the Toad World repository to use the new style dialog. If it still isn't appearing, check your Toad.ini file. There's a parameter under your [Settings] section named "CommonDialogFavorites", which is a comma-delimited list of favorites. Those entries should appear in your favorites drop-down, or in the favorites tree of the new dialog.

Let us know if you continue to experience problems with this.

-John

Hi John,

Once I select ‘Toad World’ in the Script Repository it started working.

Thanks.

I have the same issue that I don’t see favorites.

I am using Toad version 12.7 and I don’t even see Script Repository.

Hi nonubitta,

The Toad World Script Repository was removed for Toad 12.7. As a result, the new open and save dialogs wound up being removed as well.

I would recommend checking the Files -> Open/Save Dialogs tab of Toad’s Options window to make sure your “Favorite Folders” are listed. They should appear in a drop-down at the bottom of your Open Dialog.

-John