Toad World® Forums

Toad 12.9.0.71, ASH browser time filter bug

Hi,

Toad 12.9.0.71 x64 on Oracle 11.2.0.3 x64.

Whenever I define Time through “Specific” date value I do not get any result.

For testing I try to define through minutes …and have results (as it should be).

Hope this is enough to investigate.

Brg

Damir

It works fine for me. When I set the filter for a specific start and end date, I see data. Here is the query that runs when I have it set to “Active Sessions”

select TRUNC (sample_time, ‘mi’) sample_time, count(*) value
from V$ACTIVE_SESSION_HISTORY
where 1=1
and sample_time >= :MinSampTime
and sample_time <= :MaxSampTime
group by TRUNC (sample_time, ‘mi’)
order by 1;
:MinSampTime(DATE)=7/29/2016 7:37:13 AM
:MaxSampTime(DATE)=7/29/2016 3:33:42 PM

If you still think there is a bug, please provide more details so I can reproduce it. Thanks.

Yes bug is still present.

what kind of inf you need?

P.S.
Date format settings is somewhere before set or you expect that this as default on each client?

Turn on spool SQL and send me the output of the query that runs when you open the ASH Browser (with your filter set).

Also send me a screen shot of your filter.

I am not sure that I understand your P.S. question, but I hope this answers it: The filter settings for ASH Browser are controlled by the dialog that comes up when you click the Funnel icon at the top of the window (right next to the change session icon). The default setting is “not filtered”, but the filter is remembered once you set it. If the icon is red, the filter is set. If the icon is grey, the filter is not set.

PRoblem that I see now is that change “v$active…” and “DBA_ACTIVE…” result with the same data:

Timestamp: 10:17:06.425

Select decode(session_state, ‘WAITING’, Event, ‘ON CPU’, ‘Waiting on CPU’) event,

sum(decode(session_state, ‘WAITING’, time_waited, ‘ON CPU’, wait_time)) wait_time

from v$active_Session_history

where 1=1

and sample_time >= :MinSampTime

and sample_time <= :MaxSampTime

group by decode(session_state, ‘WAITING’, Event, ‘ON CPU’, ‘Waiting on CPU’)

order by 2 desc

:MinSampTime(DATE)=08.08.2016 03:00:18

:MaxSampTime(DATE)=08.08.2016 05:45:00


Session: Q383211@MOBENB0

Timestamp: 10:17:36.072

Select decode(session_state, ‘WAITING’, Event, ‘ON CPU’, ‘Waiting on CPU’) event,

sum(decode(session_state, ‘WAITING’, time_waited, ‘ON CPU’, wait_time)) wait_time

from v$active_Session_history

where 1=1

and sample_time >= :MinSampTime

and sample_time <= :MaxSampTime

group by decode(session_state, ‘WAITING’, Event, ‘ON CPU’, ‘Waiting on CPU’)

order by 2 desc

:MinSampTime(DATE)=08.08.2016 03:00:18

:MaxSampTime(DATE)=08.08.2016 05:45:00

So there is a bug definitely.

Thanks, it’s fixed in the next beta.