TOAD 15 - Login Issue - '' is not a valid integer value

Greetings , Esteemed Colleagues,

Hope you are well.
My Company has deployed TOAD for Oracle v 15.0.97 over the weekend.

When trying to login today to my established connections, I get the error :

'' is not a valid integer value

This happening for new as well as old connections.
"ping" shows successful but when I connect, this error pops up and editor window does not open.

I have tried renaming connections.ini , connectionpowds.ini and toad.ini , while toad was closed but that did not help.

the old link in the forums for does not work and I don't find any other solutions.

any guidance and pointers would be helpful .


First, you may be able to solve the problem by updating to the Toad latest version, which just came out a few days ago. You can get version 15.1 here.

If you can't do that....

Are you using Oracle client version If so, upgrade to, 12.2, or 18c.

If not, please try resetting user files as described here.

If that solves it, you can being over your connections.xml file to restore your connections.

Also, if that solves it, please zip up and send me your old user files folder (which should now be something like C:\Users\Your_user_name\AppData\Roaming\Quest Software\Toad for Oracle\15.0_bak so that I can try to find what caused the problem and fix it.



1 Like

Dear John,


To advise :

  1. Apologies, TOAD versions are pushed by IT Admins ( Infra ), so won't get 15.1 unless they push it forward to us.
  2. I usually take backup of toad user settings once a month, since about 3-4 years now ( old habits die hard ).

I tried clearing the user settings ( clean install from user settings ) , restoring my latest backup. did not work.

I also, physically deleted the 15.0 and 15.0_BAK dirs from user settings ( appRoadming/... ).
still the same issue.

3.I also followed the route of taking connections.xml backup, cleaning everything and trying a run. still the same issue.

Only this left at this point is uninstall and reinstall of toad.

PS : I am unable to add the latest images ( as new users can't embed image sin replies )

Apologies, I was unable to add the images.

Also, I have zips with me but my company policy won't allow a zip file upload somewhere.
Still, I will try. would you let me know how to send those zips to you ?

I just increased your privileges. You should be able to add images now.

I'll send you a private message for a location to upload the zip file