Toad World® Forums

TOAD and Windows 7 Admin rights


#1

The only way I’ve been able to get TOAD for Oracle 10.5 or 10.6 to
talk to Oracle on my 64 bit Windows 7 PC is to run TOAD as an
administrator. I have TOAD installed outside of the (x86) folder, I’m
using a 32 bit Oracle client and all the paths etc are set correctly.
Without admin rights, TOAD gives me the usual “Cannot initialize OCI”
error.

Is this to be expected? While it’s true that running apps as an admin
is only mildly inconvenient, it is also potentially hazardous.


WSS4CF - WS-Security framework for CF
http://wss4cf.riaforge.org/


#2

I noticed the same problem has been reported back with Vista and TOAD 9:

http://tech.groups.yahoo.com/group/toad/message/44387

Are we really stuck with running TOAD as an Administrator?

On 17 September 2010 10:38, James Holmes wrote:

The only way I’ve been able to get TOAD for Oracle 10.5 or 10.6 to
talk to Oracle on my 64 bit Windows 7 PC is to run TOAD as an
administrator. I have TOAD installed outside of the (x86) folder, I’m
using a 32 bit Oracle client and all the paths etc are set correctly.
Without admin rights, TOAD gives me the usual “Cannot initialize OCI”
error.

Is this to be expected? While it’s true that running apps as an admin
is only mildly inconvenient, it is also potentially hazardous.


WSS4CF - WS-Security framework for CF
http://wss4cf.riaforge.org/


#3

As I understand it, you need to install as an Admin, and run as a power user.

Unfortunately, I’m setup as an Admin on my machine, so I can’t add
any personal experience.


#4

Are you running with UAC on?


#5

Yes, UAC is on. If I run TOAD normally, I get the OCI error. If I elevate TOAD
via UAC, everything works normally.

WSS4CF - WS-Security framework for CF
http://wss4cf.riaforge.org/

On 20 September 2010 21:44, Brad Boddicker
wrote:

Are you running with UAC on?

#6

This is a known issue to us, when UAC is on. However, I don’t see it
documented anywhere. I’m guessing you are not allowed to turn UAC off?


#7

I take that back. Search help for “UAC”
image001.png


#8

Thanks, at least now I know It’s expected behaviour.

WSS4CF - WS-Security framework for CF
http://wss4cf.riaforge.org/

On 20 September 2010 23:39, Brad Boddicker
wrote:

I take that back.  Search help for “UAC”

image001.png


#9

One of my coworkers who just upgraded from 10.1 to 10.6 complained about TOAD
suggesting syntax for the sql commands while he is typing in SE.

Something like when he types “HA” in a second a pop-up with “Having” shows up.

How can he disable it?


#10

Check out the Editor options, have them disable support for ‘Expected
Tokens’, they can disable the feature completely as well if they do not
want it for Oracle object name completion.


#11

Do an options search for “check syntax”. I think it’s under
Code Assist options.


#12

In addition, disabling both Available Identifiers and Expected Tokens causes the
popup to behave as it did in prior versions.


#13

This option will only underline syntax errors with red squiggly lines. It
doesn’t affect the suggestion popup.


#14

Interesting. I did not find Available Identifiers and Expected Tokens support,
but I found “Enable Code Insight pick list” option after disabling it pop-ups
stopped.
image001.jpeg


#15

Interesting. I did not find Available Identifiers and Expected Tokens support,
but I found “Enable Code Insight pick list” option after disabling it pop-ups
stopped.
image001.jpeg


#16

Right, I misread the original question. Since squiggly lines are new to 10.6, my
mind jumped to that first. I’ll need some help getting out from under the
bus.


#17

There is a list box on that same form where you can toggle off various items
that are shown.


#18

Speaking of which, I have chosen to turn Code Insight off and then request pick
lists (e.g. table columns) when I want them, using control-period. But is there
a way similar to control-period to get the popup of function/procedure
parameters? That is, the popup that used to come up after I type procedure_name(
and pause?

Nate Schroeder

US Seed & Trait Commercial IT - Data Management Team

Monsanto Company

800 N. Lindbergh Blvd. LC4D - Saint Louis, MO - 63167

314-694-2592

This e-mail message may contain privileged and/or confidential information, and is intended to be received only by persons entitled to receive such information. If you have received this e-mail in error, please notify the sender immediately. Please delete it and all attachments from any servers, hard drives or any other media. Other use of this e-mail by you is strictly prohibited.

All e-mails and attachments sent and received are subject to monitoring, reading and archival by Monsanto, including its subsidiaries. The recipient of this e-mail is solely responsible for checking for the presence of “Viruses” or other “Malware”. Monsanto, along with its subsidiaries, accepts no liability for any damage caused by any such code transmitted by or accompanying this e-mail or any attachment.

The information contained in this email may be subject to the export control laws and regulations of the United States, potentially including but not limited to the Export Administration Regulations (“EAR”) and sanctions regulations issued by the U.S. Department of Treasury, Office of Foreign Asset Controls (“OFAC”). As a recipient of this information you are obligated to comply with all applicable U.S. export laws and regulations.


#19

Many thanks, this is exactly what I want.
image001.jpeg