Toad World® Forums

Windows 7 and Toad 9.6.1

Hey expeerts!

Hope someone can help me. I have Toad 9.6.1 installed on Windows 7 with an Oracle 10 Client. I can run as admin or as normal and get the same behaviour. The Login screen appears OK, but once Toad has verified my credentials I receive 3 Eureka errors, with the error being “The system cannot find the file specified”. After this I get an access violation in toad.exe at read address 00000320.

Colleagues of mine have this setup and working OK. I have tried uninstall/re-install to the same effect.

I’ve turned on debugging via the toad.ini file and this is as far as it gets (only showing the last few lines of the log)

08:49:52 Restricting product features based on Toad security
08:49:53 Checking for RAC support…
08:49:53 Out of RAC support check.
08:49:53 Fetching owner names
08:49:55 TFormToadEditor.Create

I have tried running process monitor to try to determine which file it cannot find, but to no avail.

If I ignore these errors I can use Schema Browser, but cannot get the editor window to load at all.

Anyone any ideas? I’m tearing my hair out!!

If anyone would like me to attach any further info, please let me know!

I get same error. I have windows 7, oracle 10.2 client and toad 9.6.1.1. I get “the system cannot finf the file specified” whenever I try to open editor window or connect (this opens up editor window for me as well). Looking into more info, it says “eolesyserror”.

This version of Toad is old. If you can upgrade or download the 10.6 trial you
should give it a shot and see if it addresses your issue. Much has changed in
the Editor since 9.6. If you are getting an error log popup then please send the
Toad.elf file generated which should be in your User Files folder.

Michael

I have a file called ToadDebug.txt - here is output. Thanks. I have a corporate licence installed via a control panel, so that is latest version I can have. It has been running perfectly for months, then suddenly it fails to run. When I use editor ithe errors appear.

16:21:48 Initializing application
16:21:48 Creating GlobalDataModule
16:21:48 Performing Toad’s startup tasks
16:21:48 Setting Toad help file
16:21:48 Setting global options
16:21:48 Updating license key file with app info
16:21:48 Loading Formatter Plus
16:22:12 Creating main window
16:22:12 Create Bitmaps Form
16:22:12 Checking for Spotlight
16:22:12 Checking for SQL Impact
16:22:12 Initializing Team Coding
16:22:12 Building quick scripts menu
16:22:12 Building external tools menu
16:22:12 Restoring dock layout
16:22:12 Enabling features based on license
16:22:12 Restoring size and position
16:22:12 Ribbit!
16:22:12 Performing Toad’s command line tasks
16:22:12 Application.Run
16:22:13 Create Login Form
16:22:50 Calling OCI connect
16:22:53 Connected
16:22:53 Initializing connection
16:22:53 Getting Oracle version
16:22:53 Fetch session SID
16:22:53 Checking for access to DBMS_TRANSACTION
16:22:53 Checking for SELECT_CATALOG_ROLE
16:22:53 Checking for SELECT ANY DICTIONARY
16:22:53 Checking for SELECT ANY TABLE
16:22:53 Checking access to DBA views
16:22:54 Setting module info
16:22:54 Creating Debugger Object
16:22:54 Restricting product features based on Toad security
16:22:55 Checking for RAC support…
16:22:55 Out of RAC support check.
16:22:55 Fetching owner names
16:23:05 TFormToadEditor.Create

Do you have Toad.elf on your computer too? That is really the file we need if it
is present. Check your Toad options as indicated in the screenshot. If the log
file edit box is empty then set it similar to the screenshot. I've placed my
Toad.elf file in the User Files folder. Reproduce your issue and send the
generated file.

Michael

Hi,

I am using toad 8, but when ever I want to save some out put of toad it display
junk Arabic character.

My database cherecter is “AMERICAN_AMERICA.AR8MSWIN1256”

Regards,

Sajid Elyas Khan – Senior Oracle Database administrator

Management Information Directorate

Social Insurance Organization (Pension)

Tel: +973 1751 9095 | Fax: +973 1753 2494 | Web: www.sio.gov.bh

Bldg 48, Road 1701, Block 317, Diplomatic Area | PO Box 5250 | Manama, Kingdom
of Bahrain

EurekaLog 6.0.7

Application:


1.1 Start Date : Wed, 1 Jun 2011 11:26:13 +0100

1.2 Name/Description: toad.exe - (Toad for Oracle)

1.3 Version Number : 9.6.1.1

1.4 Parameters :

1.5 Compilation Date: Tue, 8 Apr 2008 14:07:10 +0100

1.6 Up Time : 2 minutes, 7 seconds

Exception:


2.1 Date : Wed, 1 Jun 2011 11:28:21 +0100

2.2 Address : 00555673

2.3 Module Name : toad.exe - (Toad for Oracle)

2.4 Module Version: 9.6.1.1

2.5 Type : EOleSysError

2.6 Message : The system cannot find the file specified.

2.7 ID : B405

2.8 Count : 1

2.9 Status : New

2.10 Note :

Active Controls:


4.1 Form Class : TfrmMain

4.2 Form Text : Toad® for Oracle

4.3 Control Class: MDIClient

4.4 Control Text :

Computer:


5.2 Total Memory : 2048 Mb

5.3 Free Memory : 938 Mb

5.4 Total Disk : 139.18 Gb

5.5 Free Disk : 53.2 Gb

5.6 System Up Time: 1 day, 2 hours, 8 minutes, 56 seconds

5.7 Processor : Intel® Core™ i5 CPU M 520 @ 2.40GHz

5.8 Display Mode : 1280 x 1024, 32 bit

5.9 Display DPI : 96

5.10 Video Card : Intel® Graphics Media Accelerator HD (driver 8.15.10.2008 - RAM 1273 MB)

5.11 Printer : HP LaserJet 6P (driver 6.1.7600.16385)

Operating System:


6.1 Type : Microsoft Windows Vista

6.2 Build # : 7600

6.3 Update :

6.4 Language: English

6.5 Charset : 0

I have attached my toad.elf file.

Thanks.

Michael,

I have set a file (taod.elf) for exception handling. I can replicate issue without even opening a db connection. I start toad, set exception file, saved option. All oK, no errors. Then whed I press “editor”, I get following in the general error


Message was edited by: ilovegolf
toad.elf (159 KB)

It sounds like you’re missing the MSXML installation on your system.

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=3144b72b-b4f2-46da-b4
b6-c5d7485f2b42

Toad 8.x is like 7 years old – you really need to upgrade as this was
current as of Oracle 9i and then later versions of toad 8.X family were current
as of Oracle 10g. You really are asking for issues when using such an old
version of software. Do you still run windows 95 and office 95? Probably not
– so why such an old version of toad?

I do not know why this guy hijacked my thread with some oracle 8 issue. he should start his own thread.

I did not hijack that I can see – the title said toad 8 was being used so
I was helping to point out that no one should be staying on that ancient a
version of toad – there’s no official support.

i’ll try installign it and let you know how i get on - cheers

it was already there, but I reinstalled it, same error. Here is latest taod.elf file.
toad.elf (270 KB)

Sorry bscalzo, I was not referrign to your reply, but to the post/question by Sajid Elyas Khan.

Do you have the following 3 files in your User Files folder?

C:\Program Files (x86)\Quest Software\Toad 9.6\User
Files\ExplainPlancolumnDefs.xml

C:\Program Files (x86)\Quest Software\Toad 9.6\User
Files\ExplainPlanGlobalPrefs.XML

C:\Program Files (x86)\Quest Software\Toad 9.6\User
Files\ExplainPlanUserPrefs.XML

Have you tried reinstalling Toad?

Michael

I have those files but they are in different locations. Yes I have reinstalled (several times). I have windows 7 and as such my user files are in two places

virtual dir (1)
C:\Users\801785649\AppData\Local\VirtualStore\Program Files\Quest Software\Toad for Oracle\User Files

normal dir (2)
C:\Program Files\Quest Software\Toad for Oracle\User Files

I do not have them in in one dir.

I have ExplainPlanGlobalPrefs.XML and ExplainPlanUserPrefs.XML in dir (1) and

I have ExplainPlancolumnDefs.xml in dir (2)

Should they all be in both dirs?

Hello,

Toad 9.6 does not support Windows 7 and has very limited support for Windows
Vista. In order to run Toad 9.6 on Vista correctly, you have to either Turn UAC
off or Run Toad as an administrator. Another work-around would be using the
“citrix” installation option.

Here is a snippet from a paper I wrote on this:

A second issue with Toad and UAC comes into play in Toad versions 8.0 to 9.6.
Windows Vista/7 UAC uses “data redirection” with applications that
try to write to program files directory or any sub-folder within that directory.
All Toad versions prior to 9.7 write configuration files to “c:\program
files\quest software\toad for oracle\user files” or something similar. In
Toad 9.7, Toad began writing to “application data” (e.g.
C:\Users[user]\AppData\Roaming\Quest Software\Toad for Oracle\9.7, which
eliminated this problem. If UAC is on and an application attempts to write to
“program files”, the Operation system redirects all of this traffic
(reads/writes) to the application data area (where we now read/write
configuration files). It seems harmless, but it’s not. In this case,
certain files would cause issues which made Toad unusable until you manually
relocated files on your hard drive. Here is the text from release notes
regarding this issue:

Windows Vista Support

If you install Toad on Windows Vista with UAC (user access control) enabled, you
may encounter file access errors

Turn off UAC. If you don’t have permission to do this, then when files are not
found, such as lexlib.lxl, files may need to be renamed and/or moved to other
locations. In the case of the lexlib.lxl error, you must copy this file from
your local profile (where vista redirects your data) to your install directory
\user files folder.

In conclusion, if users try to run Toad versions 8.0 – 9.7 on Windows
Vista, it is highly recommended to turn UAC off. In Windows 7, instead of
on/off, they introduced various levels of UAC. The lowest level, “never
notify” is recommended in this case. Toad versions 8.5 through 9.6
included an installation option called “Citrix”. Toad version 8.0
does not include this option. The Citrix option would behave in a similar way
Toad behaves now and read/write configuration files to/from the application data
directory. If UAC cannot be turned off, then the Citrix option can be a good
work-around if available. Another work-around would be to run the Toad
application as an administrator. This option can be found via the R-click menu
from the desktop shortcut. One also may be re-prompted for a license key and new
user file created if UAC is toggled on/off in between Toad sessions.

Hi Bert,

On 01/06/11 13:21, Bert Scalzo wrote:

I did not hijack that I can see – the title said toad 8 was being used
so I was helping to point out that no one should be staying on that
ancient a version of toad – there’s no official support.

The original poster did hijack a previous thread. This from just below
his email:

Yes - my mistake and he already replied that it was not me. Guess I need to drink more coffee and pay better attention :slight_smile:

On 01/06/11 16:01, Bert Scalzo wrote:

Yes - my mistake and he already replied that it was not me. Guess I need
to drink more coffee and pay better attention :slight_smile:
I’ve had too much coffee today already! ;-(


Cheers,
Norm. [TeamT]