Toad World® Forums

Can't initialize OCI. Error -1


#1

Hi,

    I installed Toad 9.5 version successfully on Windows 7 Home Premium 64 bit and I am using Oracle 10g database. The very initial time i could able to login and working using Toad. Later one I am unable to login. I am facing the error "Can't initialize OCI. Error -1". I am using to connect to the database installed in my personal laptop.

    Request you to help me in fixing the issue.

Thanks in advance,
Arun Kumar.


#2

Right click on toad icon , choose “Run as Administrator”

Thanks


#3

Message from: hwj_140

is there any oter soultions to this problem, I got the same problem and I
can’t give all users administrator rights on the computer that program is
running on


Historical Messages

Author: hwj_140
Date: Fri Dec 23 03:20:06 PST 2011
is there any oter soultions to this problem, I got the same problem and I
can’t give all users administrator rights on the computer that program is
running on
__

Author: Syed Rahman
Date: Tue Dec 20 11:14:35 PST 2011
Right click on toad icon , choose “Run as Administrator” Thanks
__

Author: arun.gollamudi.1_000
Date: Sun Dec 18 21:16:43 PST 2011
Hi, I installed Toad 9.5 version successfully on Windows 7 Home Premium 64 bit
and I am using Oracle 10g database. The very initial time i could able to login
and working using Toad. Later one I am unable to login. I am facing the error
“Can’t initialize OCI. Error -1”. I am using to connect to the database
installed in my personal laptop. Request you to help me in fixing the issue.
Thanks in advance, Arun Kumar.
__



#4

is there any oter soultions to this problem, I got the same problem and I can’t give all users administrator rights on the computer that program is running on


#5

On 19/12/11 05:16, arun.gollamudi.1_000 wrote:

Hi, I installed Toad 9.5 version successfully on Windows 7 Home Premium
64 bit and I am using Oracle 10g database. The very initial time i could
able to login and working using Toad. Later one I am unable to login. I
am facing the error “Can’t initialize OCI. Error -1”. I am using to
connect to the database installed in my personal laptop. Request you to
help me in fixing the issue. Thanks in advance, Arun Kumar.
Toad is a 32 bit application (at the moment) and as such requires a 32
bit client (Oracle Client) to enable it to talk to databases which may
be running on 32 or 64 bit servers.

If you have a 64 bit Oracle Client installed on your desktop/laptop then
you will see this error whenever you attempt to connect with Toad to a
database.

HTH


Cheers,
Norm. [TeamT]


#6

I was thinking it was the 64 vs 32 bit issue as well but stumbled over the
information that indicated a successful connection the first time.

Here’s a possibility that might explain that anomaly:

Upon first connection a different (the 32 bit) client was selected. The 64 bit
client is set as the default and has been used since. This would explain why a
first connection would work and every connection after that would fail.

Roger S.


#7

Right-click the Toad for Oracle shortcut and select “Run as Administrator” to avoid the error.


#8

The perfect! Toad 10.6 on client 10.2.0 on windows 7 works now!


#9

Solution:-- Simple once.

Go to control panel>>Administrative tools>>Local Security Policies (Run this as a administrator)

Navigate to below Local Policies>>User Rights Assignment>>Create Global Objects

Add users windows ID by which he logged in to computer…

Apply>>OK

Now restart computer to take effect… That’s it…

Send me replies if it works for you…


#10

Send the contents of your Support Bundle. It’s available from the Help menu within Toad.

SQL Developer doesn’t use OCI to connect so it cannot be compared to Toad in this case.

Michael

From: cfb73 [mailto:bounce-cfb73@toadworld.com]

Sent: Tuesday, May 26, 2015 10:57 AM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] Can’t initialize OCI. Error -1

Can’t initialize OCI. Error -1

Thread created by cfb73

Today I siwtch on the computer and TOAD seems to upgrade itself when I tried to load it. Once the loading process was complete I had lost all my connections and passwords.

So I tried to manually type in the connection details. Each time I get:

Can’t initialize OCI. Error -1

Yes I have looked at other threads but have not found anything relevant.

I’ve unistalled TOAD and loaded back in without any success. The confusing issue is I can use SQL Developer without any issues. So, to my limited knowledge, the clients are OK.

Im not convinced its a PATH issue either since I can run Crystal Reports 2008 (32 bit) without issue and dont want to mess up the configuration.

Any thoughts?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.