Toad World® Forums

Toad crashes

Twice today I’ve had TOAD crash while I was typing in the Editor. Both times I was typing a comment on a comment line that started with dashdash (–)

No Toad.el, just a popup saying Toad for Oracle has stopped working

This last time I copied the “problem details”::

Problem signature:
Problem Event Name: APPCRASH
Application Name: Toad.exe
Application Version: 12.12.0.15
Application Timestamp: 599b1494
Fault Module Name: StackHash_3533
Fault Module Version: 6.1.7601.23864
Fault Module Timestamp: 595fa942
Exception Code: c0000374
Exception Offset: 00000000000bf3e2
OS Version: 6.1.7601.2.1.0.256.4
Locale ID: 1033
Additional Information 1: 3533
Additional Information 2: 353388b256b14457091663985489fb19
Additional Information 3: f915
Additional Information 4: f915404d497bd473fe3a01f62bfe77ad

Read our privacy statement online:
go.microsoft.com/…/

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

Recent parser update is throwing access violations. It has been logged and is being investigated.

Michael

I assume there are no suggestions on how to avoid these, such as turn off Check Syntax as you type, or such?

To be honest I don’t know. It was reported the other day and in trying to see what was going on I got it twice, from two different features using the parser. The issue seems to be somewhat widespread, but you can minimize parser utilization and see if it makes a difference.

Things to disable…

  1. Editor|Code Assist page - Check syntax as you type
  2. Editor|Code Assist page - Enable parameter assistance
  3. Editor|Code Assist page - Enable Code Insight pick list
  4. Code Analysis|Generate page - Check Rules as you type
    I’m not sure how much that will help since the Editor is always parsing for various features that can’t be disabled.

I made all the above option changes and was fine for a couple days. I just updated to .17. Within the last hour Toad has crashed twice while typing in the Editor - not unexpected based on your last statement. FWIW, the 1st time I was typing in a quoted string. The 2nd time I was typing in an INSERT statement (no quoted strings). Some of my Editor changes were recoverable :slight_smile: but still these crashes are quite abrupt and I assume could happen when another thread is executing.

Unless you have any other suggestions on what to do or not do (other than don’t use the Editor), I may need to go back to GA until a solution or work-around is available.

The only thing left to do would be to use QP5.dll from 12.11 GA in your beta. I can’t think of anything you’d miss out on by doing so. There have been some bug fixes regarding syntax error detection, etc. that may be reintroduced.

If you do that and errors persist let us know, but I think that will work in the meantime.

Michael

it seems that I have the same/similar problems with my Toad Beta (since 12.12.15 I think ?-) ) installation while typing in an editor window

when it happens then it usually does while pressing “Enter” and afterwards “Space”

-> that really might be the parser…

I tried disabling all the editor assist options too -> no effect ie still crashing at will :frowning:

so I suppose I’ll try replacing the qp5.dll…

nice “weakend”

chris

btw: now typing this in the forum part of Toad itself freezes the whole rest of Toad, argh!

Replacing the QP5.dll with the one from 12.11 has worked for me for the past several days - no crashes.

Thank you Michael for that work-around.

You’re welcome. Ideally we could just roll back to the prior version within the installer, but… since the version of the DLL would be older than the one you have installed the beta patch update would not downgrade to the prior. :frowning:

As I wrote elsewhere QP5 version 5.317 has a stability issue, we regret this. A fixed 5.318 will be available early next week.

Thanks,
Andre

the problem seems solved for me…

no crashes since 12.12.22 I think

thxalot

Chris