TOAD 16.0 BETA and - TOAD crashes using Editor

I had meant to post this earlier in the beta cycle, but kept hoping I'd find a solution.

Ever since I had loaded the 16.0 beta, I've been experiencing random crashes with TOAD while typing in the Editor window. I can never pinpoint the exact situation that causes it as it seem to be at random and with any entries I make. The error is as follows:


Seems to always indicate an Access violation with QP5.dll (ECallStack.TEurekaBaseStackList.GetFormatter (Line 2897, "ECallStack.pas")

I don't see anything captured in logs when this occurs.

I also have disabled syntax checking and parameter assistance under the Code Assist settings.

I do not see this issue with 15.1.x.



QP5 is what handles parsing and formatting of SQL.

Maybe it is caused by certain object loaded into the editor, or something that you type in, or some combination of the two.

Can you reproduce it with this info? If so, tell us how to reproduce it and we'll get it fixed.

The first "paragraph" of that error dialog is saying that an error occurred in our error-logging system, so I don't have much else to tell you.

Exactly as John wrote. Either a bug in QP5, or a bug in the code feeding it. A concrete example reproducing it is about the only practical way to track it down.


I wish I could pinpoint what causes it. When it crashed yesterday I had ran this simple query (sucessfully):


After I ran it, I went to put '%' in place of the spaces in the criteria. Just as I typed the first '%', it crashed. After I restarted TOAD, I was able to update the criteria a run the search without issue.

Generally, when I see it crash, it is when I have a bunch of searches saved in the Editor window I'm using. But each of them run just fine and there doesn't seem to be anything in common how things are coded vs. when it crashes. In all cases, there is no syntax issues with the queries. In all cases, the crashes occur just as I hit a key on the keyboard attempting to edit something. This could occur hours after I had been using the Editor as well.

But like I said, I do not have or ever seen this issue in version 15.1 and older--it's new to 16.0.

I've tried to eliminate all predictive syntax checking in the settings as well, but it doesn't seem to solve the issue.

If there is anything I can enable to allow TOAD to log everything in hopes of capturing what is occurring up until the point of the crash, please let me know.


Looking at your first screen shot again, I think I see where our error-handling code is having problems and will look at that today.

I don't have any ideas about what went wrong in QP5 though.

1 Like

Hi Bill,

Yes, you can turn on some logging for QP5.DLL. Do it like this:

  1. create a text file called qp5env.txt, in the same folder as QP5.DLL (which is in the same folder where Toad.exe is installed). I had to run Notepad as an administrator to save a file there.
  2. Make the contents of the file like this, choose a different folder if you want. qp5trace___ is just a filename prefix so just leave it like that and then you'll get several files that start with that name.
  1. Save the file and then start Toad. When you get the error, please zip up those files (there will be a lot of them) and email them to me.

Then you can delete/rename qp5env.txt to stop the logging.



Thanks John. I have QP5 logging enabled. I'll send you my logs as soon as it crashes again.


Bill, you may end up with quite a lot of trace files. They are normally around 100 kilobyte each. You'll notice a sequence number in their file name. When sending stuff to John only the latest few files are of interest (say five of them).