Toad World® Forums

Toad - Data - Foreign Language showing up mixed with English

I am running some scripts. I am noticing that on some of the data I am getting english and japanese / chinese letters included in certain columns of the results all in the single column. What is causing this and how can I fix it. I have attached a screen shot of some examples.

Any help is appreciated - this causes problems when I extract the dataset results and put into Excel.

Thanks.
Dave
Toad - Issue.docx (269 KB)

We have seen random Asian characters mixed in with the result (or all Asian characters) when using older Oracle client version. If you are not using a 12c client or newer, this may be the cause. I think it was 10g clients and older that exhibited this problem, maybe also 11g, I don’t remember exactly.

So try a 12c client or newer and I think the problem will go away.

Even I faced the same issue:

Fix:You need to connect through the Correct Client.

and also have the NLS_LANG set as :AMERICAN_AMERICA.WE8MSWIN1252

how do I set the NLS_LANG as :AMERICAN_AMERICA.WE8MSWIN1252? Where do I set that?

Thanks.

Dave

There is a good Blog on ToadWorld which explains this in quite some detail.

http://www.toadworld.com/platforms/oracle/b/weblog/archive/2009/06/01/what-is-unicode-part-1

http://www.toadworld.com/products/toad-for-oracle/b/weblog/archive/2009/06/08/what-is-unicode-part-2

From: dozier93 [mailto:bounce-dozier93@toadworld.com]

Sent: Friday, September 04, 2015 10:38 AM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Toad - Data - Foreign Language showing up mixed with English

RE: Toad - Data - Foreign Language showing up mixed with English

Reply by dozier93

how do I set the NLS_LANG as :AMERICAN_AMERICA.WE8MSWIN1252? Where do I set that?

Thanks.

Dave

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.