Toad World® Forums

Toad DataPoint 4.2 Automation Help

Hello all and thanks for letting me join.

I am having a peculiar issue and was wondering if I can get some insight on this forum. I have previously used datapoint 3.x to create simple automation scripts in Toad and they run fine. I recently upgraded to datapoint 4.2 and I get an error while compiling the scripts

cannot open 'c:\Users\xxxx\AppData\Local\Temp\1\1nv5geel\1nv5geel\CSC5B608565A4F9459392DD42E0134D2E2D.TMP' for reading

'c:\Users\xxxx\AppData\Local\Temp\1\1nv5geel\1nv5geel\CSC5B608565A4F9459392DD42E0134D2E2D.TMP' is not a valid Win32 resource file

Build failed

Had anyone encountered this on their toad and was able to resolve this? Thanks in advance!

Hi,
4.2 is not supported anymore but anyway... what is your OS? Win 10? Have you already opened a support case by any chance because this seems familiar :wink:

Hello, thank you for responding. Yes the OS is Windows 10.

Hi, I am getting the same error but in September I was able to run the same script using Toad 4.2 & Windows 10. I'm just wondering if there was a Windows 10 update that affected it.

Hi,
I am getting the same error :confused: ... Is there any workaround for this...? Thanks :slightly_smiling_face:

Have you all tried running it with admin rights?

Hi Dan, I tried that but in the current environment that needs to use an admin login which doesn't have rights to the SQL server so I was unable to try that. I also was able to go to the directory where the tmp file was being created and was able to create a file under the user without admin rights so I don't think that is the problem.

Thanks Dan! Running with elevated access resolved the issue. Apparently our org has blocked these scripts with regular user access.

Hi Dan, The task itself is running without error with admin rights when I push it manually . But it does not work for scheduled tasks , log file shows this error....

@carcari Is that something you could sort out with your IT dept.?

@toadNoob and @pokrovskaya.e Hey, that sounds like a great opportunity to find out what's going on if that fixed it for one but not the other. Are you both on TDP 4.2? Which OS do you use (run "Winver" in cmd)?

Another question, why did you migrate to 4.2 and not to the newest version?

@dan - @pokrovskaya.e and I are not in the same organization.

@dan thanks for the help Dan, it was fact that Admin rights are required.

I got it:-) But the fact that one of you solved it in the way suggested and the other one not makes you good candidates for comparison of what's different in your envs that could cause it.