Toad World® Forums

Toad For Oracle 14.0 High sys utilization & crashing when idle


Recently had some issues with crashing on 2016 R2 X64edition toad for oracle, routine crashes and high system utilization before any connections were even established and frequent crashing and locking up. It had worked normally in the past just in the past few weeks it started to really bog the system down.

Several co-workers had updated or were running release 14.0 (2020R2x64) , so I decided to download and install the newest version. Originally I tried to just install the new version so that it would update and keep the existing connections which seemed to be true but I was still seeing the exact same behavior just after launching Toad I was seeing 2.5-3gb of ram being utilized before I even connected to anything.

I thought the old version could still be causing some issues so I closed everything down uninstalled 2016 R2 X64 (made a export of connections so I wouldn't loose those) then uninstalled it restarted. Now launching with only 14.0 (2020R2x64) installed I see the same thing again 2.5-3gb of ram usage and almost 10% cpu on idle. Clicking on anything causes anything to freeze and Toad to lock up.

I feel like maybe some config related piece or perhaps registry key is corrupt or stuck from the 2016 R2 installation and got carried over when i tried to re-install 14.0 (2020R2x64) ?

I can certainly provide screenshots and or versions (oh and this is running on windows 10 enterprise) I'm just at a complete loss at the moment of what else I can try, and would appreciate any thoughts or suggestions!

I feel like there is something in your settings that is causing this.

Can you zip them up and send them to me?

Instructions on how to do (as well as my email address) that can be found here: Minor GUI Issue with Beta - #12 by JohnDorlon

After you send them, you can probably solve it by resetting your options (you can then import your connections in again if you want). Instructions on how to do that are here: Toad for Oracle not working after in place upgrade to Win 10 - #2 by JohnDorlon (ignore the part about the Oracle client)

Thank you for the quick response,

I did try the restting options, it crashed after doing that but after a force close and re-launch it seems like it was functional and utilizing resources at a a normal rate.

I will comment that despite originally exporting my connections with passwords included using a master password it only imported them sans passwords with no ability to provide the master password, must be to big of a version difference i would assume. But that is something i can live with. I will follow-up later after some usage to make sure everything is still operating stable

If Export/Import of connections is all happening on same PC, you can just copy Connections.XML from the old version's user files folder to the new version's user files folder, and password will be included.

Regarding export/import: The "Master password" option is only enabled if the "Save passwords" box at the bottom of the login window is checked (this has been fixed for Toad 14.1 beta, which you can get here if you want. Toad for Oracle 14.1 Beta. The 14.1 beta has had a lot of bug fixes. You will probably find it to be more stable than 14.0).

Thanks for your User Files.
If you look in your User Files folder, you'll see a bunch of files named like ~ebxxxxx.tmp. These are editor backup files, so you can recover your work if Toad or windows crashes.

It's OK to have a bunch of these, but one of them is a 226 MB script full of insert statements. That's what's hurting you.

You can look at it with notepad or any other text editor to see what's in there. If you don't need it, delete it. If you do, rename the file so Toad won't try to load it into the "recover documents" window on startup.

Thanks and that would make sense around the timing of when things started to get bogged down. thank you for reply and i will bear that in mind for the future and try and keep the editor backup files down/cleaned up in the future!

You're welcome. I'm working on a fix for 14.1 so that giant Editor Backup files don't cause this problem anymore.