TOAD for Oracle 15.1 and 16.0 BETA - Issue with Synonyms Tab in Schema Browser

I've found that in both 15.1 and 16.0 beta when I click on the Synonyms tab in the Schema Browser the application goes unresponsive indefinitely. When I check Task Manager (Windows 10), I can see TOAD continuing to consume more and more memory. If left, it will consume all available memory and I will start getting Out of Memory errors and my laptop starts becoming unstable. Once I kill the TOAD process, things return to normal.

I cannot tell what my previous filters are on that tab and cannot clear them because as soon as I switch to it the freeze and memory issue occurs. Not sure if anyone else is having the same problem or not. I know in 15.0 and earlier I didn't not see this issue. I have watched my Oracle session from another laptop and found it is not actively reading from Oracle, so I do not know what data it's reading to consume all 20+GB of memory.

Thanks for the report.

It looks like this happens when public synonyms are loaded.

To reset it:

  1. Close Toad.
  2. Go to your User Files folder.
  3. In it are files named (logon schema name).SBFLT.
  4. Delete the files that correspond with whatever schema you were logged in as when the problem occurred. OR...edit the file and replace <SynPublic>True</SynPublic> with <SynPublic>False</SynPublic>

Thanks John. That fixed the immediate issue. I'll avoid changing it back to see Public Synonyms until after it's fixed in an upcoming release.

You're welcome. After looking a bit further, it seems to be more related to loading "a lot" of synonyms, than them actually being public. I think as long as you avoid loading more than 500 to the list you'll be fine.

When I do a simple check of ALL_SYNONYMS, there are 11,000+ pubic synonyms ... ~8,200 of them owned by SYS. So, I would be definitely over the current limit of 500 by including them.

Yup, there are a lot of public synonyms. We'll have this fixed in the next beta.

Hello, I have the same issue (Toad but I cannot find anywhere (logon schema).sbflt files in my file system. Do I need to set some Toad settings to generate these files?

Hi @alessio.campani

The .SBFLT files would be in C:\Users\<YOUR_WINDOWS_USER_NAME>\AppData\Roaming\Quest Software\Toad for Oracle\15.1\User Files\

The file may not exist. If it doesn't, there would be no need to change a value there because we don't load public synonyms be default. In that case, you probably have more than 500 private synonyms.

In that case, you can do this instead:

  1. Start Toad but don't open Schema Browser yet
  2. Go to main menu -> Session -> Schema Browser Filters
    In this dialog you can set the default filters in the Schema Browser
  3. Select Synonyms on the left
  4. Change settings any way you want to limit the results so that you'll get less than 500 of them. Maybe you want to do "starts with A", or only get synonyms for a certain object type. Whatever works for you is fine.
  5. hit OK, then open the Schema Browser and go to synonyms. It will be filtered however you configured it for step 4. You can change the filter from the schema browser if you want to.

After you follow these steps, you'll have a file called TOAD_DEF.SBFLT in the folder mentioned above.

Toad version 16.0 will be released on April 26th and this will be fixed. It is already fixed in beta, which you can get now. Get the beta version here.

Hi John, thanks for your quick reply. I have just tried what you suggested and it worked.
I think we'll wait until 26/04 to download the new release.

1 Like

Hi John,
I installed the new version of Toad and everything works fine with synonims, thanks.

1 Like