Toad for Oracle appears an alert with ORA-29275: partial multibyte character when i execute session browser feature on Toad for Oracle.


I’m trying to use Session Browser feature on Toad for Oracle.

When I connect to Oracle Database on Toad for Oracle then execute Session Browser on Toad for Oracle, Toad for Oracle appears an alert with “ORA-29275: partial multibyte character”.

So I made change NLS_LANG value to AL32UTF8 on My PC registry editor then tried to execute it on Toad for Oracle.

But the issue is still happening on Toad for Oracle.

Can you provide me some advice for resolving the issue?

Here are Oracle Database own information.

Database version: 12.1

Character set: AL32UTF8

Thank you in advance.

Others have reported this problem.

It seems to happen when characters put into the MODULE or ACTION column are incompatible with the database character set via DBMS_APPLICATION. It can also happen with the OSUSER column.

Toad 12.12 works around the problem, so if you update your Toad the problem should go away.

Hi, I have the same issue trying execute "select * from v$session". The problem is in cyrillic characters in ACTION column. Toad version is

Please try this in the 13.2 beta. I believe it is fixed.

you can get the beta here.
Download the same version (32 or 64 bit) as what you have for 13.1.

Hi jdorlon,
I face the same issue in 13.2 Beta version

@Gulnara, are you just running "select * from v$session" in the editor, or are you opening the Session Browser and getting an error there?

I believe the problem is fixed in the Session Browser by using TO_SINGLE_BYTE() around the ACTION column

If you are just running "select * from V$Session" in the'll need to query with TO_SINGLE_BYTE. This is not a Toad problem, it's an Oracle problem.

@JohnDorlon, I also tried to open Session Browser - same result. I still face ORA-29275: partial multibyte character.
May be it is Oracle problem, but I can execute "select * from v$session" in Oracle Sql Developer without problem.
And I want to use Toad, not Oracle Sql Developer.

In 13.2 beta, go to main menu -> database -> Spool SQL -> spool to screen.

Then open Session Browser.
Spool to Screen will capture the SQL that Toad makes, and the error.
Please post that output here.

Something in your environment isn't compatible. Maybe SQL Dev is using a different client with different settings.

I was able to achieve cyrillic in V$SESSION.Action without any errors. You can see all my settings below.