Toad World® Forums

Toad for Oracle freezes after clicking "Connect"


#1

I just spent most of my day troubleshooting this problem.

to reproduce:

Open Toad
Click “New Connection”
Enter Direct Connection: **Host, Port, SID **(tried connecting by host name or IP)
Connect Using: OraClient11g_home1 (also tried “Instant client 11.2.0.1.0”)
click “Connect”
[ FREEZE ]

Troubleshooting i’ve done:

I am able to telnet to that host:port

netstat -a tells me that the connection to that host:port is ESTABLISHED (by TOAD)

I profiled using Process Monitor, and i can see that TCP Send from: MyMachine:52302 > host.domain.com:port is a SUCCESS

i am also able to connect instantly using Oracle Sql Developer

  • more developers at this location have this same exact problem.
  • some developers are able to connect no problem.

i am using Toad for Oracle 11.0, but i also installed 12.0 trial version to get the same problem

**It appears to me that Toad is doing something after establishing a TCP connection on the UI thread, but i haven’t been able to figure out what that is… **