Toad World® Forums

Toad for Oracle Suscription problem

Hi,

I would like to ask that I'm testing the new version Toad for Oracle Suscription and when I try to sing in I have the same error. The problem is that on that computer we are using a proxy, so I cannot find where I should put my credentials for proxy settings in order to be able to connect.

The error is:
[ERROR] [2020-12-18 11:55:45:544] - Response: 10060, Description: 10060: [10060] Connection timed out

I have Internet connection but using a proxy

I hope someone can help me.

Thanks in advance.
Regards

Hi,

You should be getting prompted to enter proxy credentials before Toad even loads.

The first thing I would try is to make sure Toad is not running on your machine. Be sure you don't see any toad.exe process running and if so, kill them. Launch Toad again and look for that prompt. In my testing, I've seen that credential prompt get lost, so when you try this, be sure you're not clicking on any other applications after you launch Toad. Also be sure to check secondary monitors for the prompt.

If that doesn't work, you could try to clean up any app data that might have been created. Rename or delete the following folder if it exists then try again:

C:\Users[User]\AppData\Roaming\Quest Software\Toad for Oracle\14.0

Another possible issue could be that you've got bad credentials stored in your windows credential manager for this proxy. If Toad finds credentials for your proxy server in the windows cred manager, it will try to use those first. I would expect a re-prompt if it fails, but there is a chance it could be failing silently. Clear out any saved proxy credentials for your proxy server and try again.

We have been able to test Toad Subscription successfully under this scenario, so I'm hopeful we can find a solution for you. Let us know how it goes and if it fails again, please tell us what you're seeing right after you try to launch Toad. Do you see Toad show in your task bar?

Thanks,
Brad

Morning!
I continue having the same problem. I have done everything you told me. The problem is the proxy of my company on this computer. I have tested on another computer, my personal computer which I don't use proxy and there TOAD works.

I only receive the window where I need to put my Quest credentials but I receive the same error:
An error occurred while signing you in.

'Your machine is connected to the internet, but an unknown error occurred that prevented your license from being validated successfully.
Please try signing in again.'

Thanks in advance

Interesting.... so you do not receive a prompt for proxy server credentials at all?

I have been assuming your proxy is setup with authentication, but maybe that is the wrong assumption?

Can you sign into your account outside of Toad by going here or do you get the same error? https://licensing.toadworld.com/licenses

Hi mrgarciagil,

Toad for Oracle Subscription will use the proxy settings defined within Windows. However, if your proxy is configured in Windows automatically through a PAC (proxy auto-config) file, Toad for Oracle Subscription doesn't fully support that kind of proxy configuration yet. If you can statically enter your proxy server information into the Proxy settings within Windows, Toad for Oracle should read and use those configuration settings when connecting.

I hope that information helps in providing a workaround. Please feel free to let us know. We expect to have a fix for proxy auto configs soon within the Toad for Oracle Beta program.

Thanks, and I hope you have a good holiday season!

-John

Hi!

Thanks for answering. You are right. My proxy is setup with authentication.

I can sign into my account using the URL https://licensing.toadworld.com/licenses because when I open my browser I have always to put my proxy credentials but when I open TOAD program it doesn't happen.

Thanks again

Hi John!.

Ok, thanks for the information. I tried to enter my server information into Proxy setting within Windows but I didn't able to do it because it is controlled by the network where I'm working, so I think I'll have to wait for new versions of Toad.

Thanks and have a good holiday season too.