Toad World® Forums

Toad version 12.12.0.39 Error


#1

when starting toad i get the following error, but i can click ok and lets me connect:
ons_subscriber_create_wtimeout_ctx could not be located in the dynamic like library:
c:\app\oracle\product\12.1.0\client_1\bin\oraclient12.dll.

Should I just try and reinstalling application?
I’m running win10 with oracle 12c package


#2

Do you have more than one Oracle client installed? Normally this is OK, but I have occasionally seen similar errors if 12.1 and 12.2 are both installed. If that is the case for you, try using the ‘other’ one and see if that resolves it.

Restart Toad before switching to the other client. There is a place on the login window where you can tell it which client to use.

If you really want to use the client that you are already using, make it the first one in your system path.


#3

No, this is a new install.
Capture


#4

hm, never seen it with one client before.

I don’t think reinstall of Toad will help. I’ve used 12.1 successfully so I’m not sure what’s wrong, but you could try uninstalling the 12.1 client and installing 12.2.


#5

on the pc we have oracle11 and 12. When we use 11 it gives no error. Just on 12. I have reinstalled toad 12.12 and still get the same error. I’m not sure how to change the path for clients as some suggested online. I would need to test this due to the environment we are using. Thanks.


#6

If you don’t need both clients installed, then the simplest solution would be to uninstall the Oracle 11 client. If you need both, read on.

Sometimes Toad has problems if:

  1. start Toad, make a connection using one Oracle home.
  2. end the connection, but leave Toad open.
  3. make another connection with a different Oracle home

If this is what’s happening for you, try closing Toad completely on step 2.

On the other hand, if you just start Toad and try to connect the first time with the Oracle 12 client, and get the error right away, maybe changing path would solve that.

To change path:

  1. In windows, click Start, then rt-click on ‘Computer’ and choose ‘Properties’
  2. in the window that appears, click ‘advanced system settings’
  3. in the next dialog that appears, click on the ‘advanced’ tab.
  4. click ‘environment variables’
  5. find ‘path’ in the ‘system variables’ box.
  6. edit the path so that the version 12 client comes before the version 11 client.

Click OK on all the dialogs, then try Toad again.