Toad World® Forums

Toad for SQL server v7 gets very slow

Toad for SQL server is fine when first opened but gradually gets slower and slower to the point where I have to wait for what I have typed to appear in the editor.

I have recently moved from SSMS where I never had this problem.

Any suggestions?

Hi,

Can you try disable code completion and use editor without it?
Can you send me Support Bundle and script that you're editing to vasiliy.fofanov@quest(dot)com?

Hi Vasiliy

clicking on the support bundle option in the help menu does nothing? no tab appears.

I have unticked all options in code completion.

Script is attached.

Regards

Robert Morgan | Senior BI Analyst IMT, ICT Department | Whanganui District Health Board
**p (**06) 348 3158 | extn 8158 | www.wdhb.org.nz

'Better health and independence'
'He hauora pai ake, he rangatiratanga'

IPView.sql (8.38 KB)

I just upgraded to 7 from 6.8 and the editor gets so slow at times that as I type I have to stop and watch the letters being displayed one by one, one per second. The arrow keys are fine, the cursor moves fast between lines. And here is what I noticed - it depends on where you are in the editor. I have some pretty big insert select statements (the table I am inserting into has 90 columns) and lots of conditions to check for changes in those columns. I noticed the editor slows down when the cursor in the proximity of these big queries, i.e. inside the query or one line before the query. When I move away from those statements in the editor, then it gets its brains back and it's fast again.

Can you please, please, please get this fixed ??

It should be easy to reproduce, you must have your own test database, just create a table with lots of columns and create dummy big queries and see how your editor behaves.

An update: I took a look at the sql file posted by WDHB and I think I am experiencing the same issue he is having. Some of my queries are as big as that one or even bigger.

Clearing the checkboxes under Code Complete doesn't make any difference. Also disabling the Syntax Checking doesn't seem to have any effect, Toad still does some checking - for instance it checks that the number of columns specified in the insert matches the number of columns in the select in an insert/select statement.

Another one I noticed, editing gets very slow around case statements even when they are short.

Any other ideas to find an workaround?

Sorry, one more thing unrelated - it may deserve a separate post - but updating the options takes a very looooong time - at least the first time. Long as in minutes. I don't have the fastest machine but it is long.

Update 2: I gave up on using Toad 7 at least for developing stored procedures. The editor becomes insanely slow as I am moving from query to query in a big stored procedure. I am switching back to Toad for SQL Server 6.8 until this gets fixed.

Thanks