Toad World® Forums

Toad Sql Editor is slow to respond

All,

I keep getting complains about slow speed of TOAD SQL editor when people are typing fast. It is clearly much slower then regular editors like notepad or even SQL developer.

It affects all recent versions 11* and 12*

Is there an option(s) that can be turned off to speed it up?

Many thanks.

Change the highlighter from PL/SQL to Plain Text via the rt-click Language/Syntax Highlighting menu in the Editor and type quickly. If the performance issues
are resolved then it’s the highlighter. The highlighter parses the text using regular expressions which is less than ideal.

You could try all of the following that you can live with to see if performance improves.

Disable “Enable code folding” on the Editor Behavior options page.

Click “Auto Replace…” on the Editor Behavior options page and disable it.

Click the “Syntax Highlighting” button on the Editor Behavior options page and select the Rules tab.

a.
Disable capitalization effects. On the Highlighting tab, select each style and set “Capitalization effect” to unchanged.

b.
If you disabled Code Folding then you can disable all of the lexer rules that identify folding regions. Having them enabled is excessive. These would
be all rules that have a start and end rule counterpart. For example, the “ToadFold” and "ToadFold " rules are a pair and you would disable both of them. You’ll see several other “XYZ” and "XYZ " pairs throughout. Select them all and disable. Your
syntax highlighting should continue to work without this extra processing. Note that this will also disable dynamic highlighting of matching parenthesis, etc.

c.
If you chose to leave folding and those rules enabled then select each of them and uncheck “Draw block staple”

d.
If you’re not using the option to highlight table/view/proc names then you can disable the “Toad_” rules. Leave the Toad_Datatypes enabled if you like
datatypes highlighted differently from other reserved words, otherwise disable it too.

e.
If you don’t use Java Source having the Java sub-language enabled is excessive. See the Sub Languages tab and disable it.

Increase the timer for code assistance or disable it altogether. See the “Delay pop-ups” option on the Editor Code Assist options page. Having this
set to something slower than typing speed means that extra processing and potential query execution occurs at that interval. The default value of 1500 ms allows for very slow typing without processing. If you have it set to 100 ms and can’t maintain 10 chars
per second then a lot of processing is happening which slows everything else down.

Try any of those you can live with and hopefully it will help. The root issue of using regex to parse the source for highlighting is hard to overcome especially
in large text. A component swap is underway that will increase the speed quite a bit. I hope to have it in beta soon. I’ve been testing with huge files and performance is good.

Michael

From: gmeltser@aigfpc.com [mailto:bounce-gmeltseraigfpccom@toadworld.com]

Sent: Monday, November 10, 2014 2:24 PM

To: toadoracle@toadworld.com

Subject: [Toad for Oracle - Discussion Forum] Toad Sql Editor is slow to respond

Toad Sql Editor is slow to respond

Thread created by
gmeltser@aigfpc.com

All,

I keep getting complains about slow speed of TOAD SQL editor when people are typing fast. It is clearly much slower then regular editors like notepad or even SQL
developer.

It affects all recent versions 11* and 12*

Is there an option(s) that can be turned off to speed it up?

Many thanks.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

I do not know if mine hint is covered under suggestion under MIchael’s posting:

Editor|Code Assist|Toad Insight Objects

and uncheck “Public synonyms”

Hope this helps,

Damir

I’m getting this issue as well.

Toad is running over Citrix so our Infrastructure guy has been able to do some checks.

Toad isn’t releasing the memory up after it’s exported a report, Excel for instance.

Eventually Toad comes to an unusable speed and the user has to totally close out Toad and Citrix, then start again.

As Gmelster mentioned before, typing or selecting text becomes slower and slower.

The actually running of a complex statement and pulling information from a database isn’t an issue.

It doesn’t sound like any of those options given will fix a memory issue??

Can you advise?

Thanks