Toad World® Forums

Toad hangs on a simple query

All,

I’m on Beta 12.8.0.27 which hangs on a simple query:

select xmlelement(“SOAP-ENV:Envelope”, ‘hoppa’) from dual;

I guess it’s Oracle (9i) not returning an answer. Not much Toad can do about that.

However, after hitting Escape, Toad cancels the query and returns to edit mode, but when I try to close the edit window, Toad goes into a hang.

Kind regards,
Abe Kornelis

Ok, I tried the same query on an old version of Toad. This time I got an error message (ORA-3120), rather than a hang. Seems the new version is either gobbling up or totally unaware of the error message beign returned from Oracle.

Toad_20151008_missing_error_message.png

Hope this helps,
Abe Kornelis

Are you running with F9 or F5 (execute as a script). If you’re using F5, it’s really not the best way to return data in Toad. Try F9 instead.

I get an error message if I run that query with an Oracle 9 client, but if I use a 10g client, it works fine.

Gregory,

I used Ctrl-Enter. Just tried F9: same thing. I.e. emty data grid, and the in-progress runner at the bottom right just keeps on going. Surely, 2:21 (and still counting) should be ample time to respond to this query!

Abe

What about using getclobval() function at the end of xmlelement? Does it work for you?

Sorry, that does not work. I get: Invalid Identifier.

However, this does work:

select xmltype.getclobval(xmlelement(“SOAP-ENV:Envelope”, ‘hoppa’)) as test from dual;

Thanks a lot for pointing me in the right direction!

Abe Kornelis.

GetClobVal comes at the end, like this:

select xmlelement(“SOAP-ENV:Envelope”, ‘hoppa’).getclobval() as test from dual;