Toad World® Forums

Toad query is omitting a different single record each time

I am running a query and for some reason it leaves out one record each time. Not only that, but it is a different record each time I run it. I have verified this by comparing the results with a query from Hyperion’s Brio. I have posted some screen shots in the photo section. The Brio query is correct with the total sum that I am looking for and has 11564 records. Every time I run the Toad query, it only gives 11563 records and the sum is different every time, so I assume it is leaving out a different record each time. I have posted a shot of the two different SQL statements to show that they are the same. What could be causing this?

Thanks

I should probably give you my version info:

4.7.1.638
Registered Version

Hi,

I’m having trouble interpreting the images you posted. Will you please email me your query and theDDL for the object?

Also, is the target db LUW or z/OS?

Regards,

Adam

adam.ririe@quest.com

I am still experiencing this issue. Has anyone else seen this or know what might be causing it?

Thank you.

We’ve reproduced this problem and we’re working on a fix.

Thanks,
Adam

Has a solution to this issue been found? It is very annoying and almost makes using Toad unacceptable for what we are using it for. We need to be able to see all records in a database to verify information, however Toad is dropping random entries. I have noticed it only happens above a certain number of results that I feel is close to 10,000.

The Toad DB2 4.7.2 patch\release contains the fix for this issue.
You can downlooad that release from support.quest.com.
(The fix has also been available in the Toad DB2 5.0 beta drops.)

Hey, Jeff, this is Kathryn Ericsson. Do u remember me from FMC???
How r you guys doing?
I was working with John Hood at HSBC a while ago.
I don’t know how to message you directly, so I just posted this here, hoping you’ll see it.

Kathryn,
Indeed I do remember you from the old FMC days.
My direct emai is jpodlasek@quest.com please send me an email there directly and we will catch up.
Jeff