Toad World® Forums

<<toad>> regarding an issue in opening package


#1

Hi,

When I am trying to open “spec” or “body” section of a package in toad then it’s
giving me following error and the “spec” or “body” is not opening for the same.

I have attached the screenshot of it:

Please suggest me solution to resolve this issue.

Thanks & Regards,

Richa Kalra

image001.jpeg
image001.jpeg


#2

Look a few messages back before yours – the same question and answer were
just posted.
image001.jpeg


#3

This has to do with using a very old version of Toad and an Oracle that is
version 10 or later.

There were several replies to a similar question earlier this week. One
suggestion even suggestion making changes to your Oracle views so it will work
but then opening yourself to a loss of oracle support because of the change. The
simplest (and only acceptable) solution is to upgrade.
image001.jpeg


#4

This has to do with using a very old version of Toad and an Oracle that is
version 10 or later.

There were several replies to a similar question earlier this week. One
suggestion even suggestion making changes to your Oracle views so it will work
but then opening yourself to a loss of oracle support because of the change. The
simplest (and only acceptable) solution is to upgrade.
image001.jpeg


#5

#6

I would treat that last option with a major caveat. How many people set their PC
calendar date back to squeeze more time out of trials? Most people don’t
do that because it screws up your anti-virus signature dates – and leaves
you more open to viruses. As a DBA at heart – I would never allow a
production or even test database under my management to be modified where we
changed a data dictionary view. No matter how seemingly safe – if I ever
had to call Oracle tech support and they got wind of it – I would expect
them to hang up on me. Thus I would never advise anyone to do this other than
maybe a dev or purely local playground database. But that’s just me J