Toad World® Forums

Toad save as excel -> turkish characters not saved properly

Hi,

I can see Turkish characters properly in grid result of a query in Toad for Oracle. However, when I do right click over datas and click “save as” excel format, it does not export some Turkish characters properly. (For example, excel shows ‘Ý’ char as ‘Ý’, ‘Ð’ char as ‘Ð’…)
I don’t wanna do replace for all problematic characters one by one in excel.

Also, Toad->save as-> set locality -> select an excel file containing problematic but properly shown Turkish chars sets Locality to 1200, but has no effect as solution.

What can I do for this problem?

Thanks for any suggestions…

Zehra

First of all, run the “Excel” program and do the following works.

If data is displayed on your “data grid”, click the right-mouse button and select “Export Dataset…” menu.
Now the “Export Data” window will appear.
Select “Excel Instance” from the “Export format” list and check the options what you want.
Finally click the “OK” button and look the excel instance.
The data will be good.

Thanks for your reply,

I was selecting “Excel File” instead of “Excel instance” in Save As ->“Save Grid Contents” menu in Toad. Selecting “Excel instance” opened the characters properly.

The thing that I could not understand is if Toad could save as “Excel instance” why it could not save as “Export File” ?

Thanks…

Saving as “Excel File” and “Excel Instance” are 2
different technologies. In “Excel File”, Toad creates the file
without any interaction from Excel. You don’t even need to have Excel
installed to use this option. In “Excel Instance” Toad communicates
with a running instance of excel.exe. We tell Excel what values to put in what
cells. Saving the file at that point is up to you and Excel.

What version of Toad are you running?

In my opinion, these is because of the difference between “memory-memory copying” and “memory-disk copying”. During the process of copying from memory to disk, the special characters(especially 2-byte character like Turkish character, Korean character, Chinese character, Japanese character, etc.) don’t being copied properly to disk.
As well as above, there may be some problems in Toad, such as the unicode conversions or charset conversions methods.
Anyway, the problem solved. This is the result and aren’t you happy?
If you are happy, everything is fine!
Don’t worry and be happy.