Toad World® Forums

Saving TOAD grid to Excel - numbers are all general format

Hi, Folks - I’m brand new to this forum. I’m a functional Oracle consultant focused on the eBusiness applications. I use TOAD v8 to extract data and save it to Excel for various client information needs.

I’ve noticed over the last few days that when I save my grid results from TOAD to Excel, all of my numbers are ending up in Excel with “general” formatting which forces me to add a step to multiply them by 1 in order to apply math to them. This is driving me nuts. I don’t remember this happening in most of my past experience with TOAD and I don’t remember changing anything. I even made sure my “Use only ‘general’ cell formatting” option is turned off in my Save Grid Contents window (see screenshot below).Does anyone have any idea what I’ve managed to turn on or off that is controlling this?

Thanks for any suggestions - Travis

I didn’t see your screenshot, will you send it as an attachment?

It’s been a while since Toad 8, but I don’t remember anything other
than that option.

Are your numbers coming from NUMBER columns in the database, or are they
VARCHAR2 columns?

Thanks so much for your response. Apologies for this missing screenshot. Please see attached Word document for sample table description, grid save options, and Excel output. I appreciate your continued help. Travis
TOAD_Screenshots.doc (126 KB)

Sorry - forgot to mention in the thread. Columsn are NUMBER data type.

It’s kind of a shot in the dark, but you might try checking ‘clone
cursor’.

Thanks for the clone cursor suggestion. Unfortunately, no luck.

Travis
I had a slightly similar problem in Toad 9.7.0 - DATE type columns would appear in Excel as numbers - and fixed it by upgrading to 9.7.2.

I’d recommend this, if you are able to do so in your location.
Jason

Thanks, Jason, for the tip. I’m checking my options with Quest right now. Travis

If you are referring to me, Travis, I’m afraid I’m out of ideas.
:frowning:

Hi, Folks - Thanks again for taking the time to reply to my problem. I found the solution after registering with Quest Support.

Solution SOL11461 has the answer!

TITLE: Unable to Sum Numeric Columns After Exporting Data to Excel Spreadsheet
DESCRIPTION: After saving results from the data grid to an Excel spreadsheet from TOAD 8.0, some of the numeric columns may be formatted as text and thus not allow users to sum the columns.
RESOLUTION:

  1. Go to View | Options | Data Grids | Data
  2. Check the option to “Display large numbers in Scientific Notation”
  3. Press “OK” and restart TOAD

I must have unchecked that option sometime in the recent past.

Thanks, again. Travis

I am quite attracted by this topic. I don’t have much experience in the Toad Grid. I ever have cope with some WinForms grid control, however, I didn’t tried export grid data to excel before. This question did great help to me!