Toad World® Forums

Toggle word wrap with shortcut

Can we define a shortcut key to toggle word wrap in the Editor component? I just find the Options|Editor|Behavior|Word wrap option, but this is quite complicated for me to always turn on/off for a wider script file. For Notepad++ there is a shortcut in View menu point.

Does it any function difference between Editor word wrap and Data grid|Pop-up window word wrap?

Functionally the two are the same, there’s just no toggle surfaced in the editor. I’ll log this to visit at some point this release.

Thanks Michael.

Would you add “Show EOL” function to the Menu Shortcut list, please? This is also a missing feature comparing to 12.6.

Thank you.

Toggle Show EOL, Toggle Show Whitespace, and Toggle Word Wrap commands added for next beta. Default shortcut for each is unassigned.

On 03/11/2015 09:26 PM, drbubo20 wrote:

RE: Toggle word wrap with shortcut

Reply by drbubo20
Would you add “Show EOL” function to the Menu Shortcut list, please? This is also a missing feature comparing to 12.6.

Thank you.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Thank you.

I’ve turned off Options/Editor/Behavior/Word wrap option, but it has no influence on popup editor - it is always word wrapped. Could you tell me, how to turn it off permanently?

Popup Editor should always start word wrap disabled. How are you getting to the popup? I have a sample table with long VARCHAR2 column and after selecting from the table when I double click a cell in the grid the popup is not word wrapped.

Michael

I’m opening popup by double clicking a cell in the grid. Popup is always word wrapped. I can toggle it off with the button in the toolbar, but next time I open the popup, it is word wrapped again.

I only get word wrapped popup editor on open when the Word Wrap option in Options|Editor|Behavior is enabled, but not disabled. Can you confirm that the option is unchecked for for you and if it is try restarting Toad and again confirm that it is unchecked and check the popup editor once more. If the option is unchecked and word wrap is still applied then I’ll need your user files to try here. You can export your settings files using the Utilities|Copy User Settings… menu item. Email me the zip file to michaelstaszewskiquest.com.

Thanks,

Michael

As you can see in the attached pictures, in Toad options word wrap option is off, but in popup editor it is on. Everything after todays fresh start of my pc.

I will email you my settings.

That screenshot clears it up. You are posting to Toad’s beta forum (we’re on version 12.11) but you are using and old version of Toad. The issue is resolved in newer versions.

On Apr 5, 2017, at 3:52 AM, bilon bounce-bilon@toadworld.com wrote:

RE: Toggle word wrap with shortcut

Reply by bilon
As you can see in the attached pictures, in Toad options word wrap option is off, but in popup editor it is on. Everything after todays fresh start of my pc.

I will email you my settings.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta Forum
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.