Trace File Browser Issues

All of this is 12.10 32bit on Win7.

  1. The default Directory on ‘Select file from database server…’

Can the Directory default be the last selected vs. what seems to be the greatest T% named directory? The TOAD% generated one was always right and my default until I installed SQLT which adds three TRCA$S% directories. Now it defaults to the last T%.

  1. Filter default

Is there a way to preserve the filter? My logon trigger embeds my username in the trace file name. It would be nice to fix it as char.trc.

  1. Open file in external editor

It never launches or opens anything. It did many releases ago. Navigating 20 directories to get to it is painful…almost enough to get me to finally make a shortcut.

Hi Chuck,

  1. The directory defaults to whatever directory points to the BACKGROUND_DUMP_DEST folder on the database. So I’m thinking that these TRCA directories probably point to the same location, and either one should work. Can you check that for me?

  2. That “open file from server” window is used for trace files, programs, libraries, scheduler jobs, and BFiles. I’ve made a change so that it will remember the last used filter (and most 10 most recently used filters) for each of these separately.

  3. Several versions ago I made a change such that we kept the file open so we could quickly jump to any part of it while viewing in the Trace File Browser. That caused other problems and it doesn’t do that anymore. Can you try this in the beta and let me know if it works better there? It works fine for me in 12.10 with notepad, but maybe whatever editor you are using requires a lock on the file.

  1. It does point to the same. That’s the last created and highest alphabetical. That’s good enough for me. I just never looked at the actual directory path when it selected the new option.

  2. Good to know and thanks!

  3. Big Brother won’t let me play with Betas, but you have cleared the fog. I had notepad++ defined in Toad Options as my editor. Changing it back to notepad or UltraEdit works just fine.

Thanks again!