Toad World® Forums

Trouble configuring Toad for oracle 9.7.2 with instant client

I have succesfully setup the instant client with sqlplus connecting to database correctly. Now on starting Toad 9.7.2 My service name as specified in the tnsnames.ora does shows up under database but there is no instant client showing there . Earlier i had ran TOAD 12 TRIAL and it it worked with the same instant client nicely .

what is wrong with this previous version of toad .

PLATFORM -MS WIN7 64 bit

INSTANT CLIENT basic and sqlplus Version 12.1.0.1.0 for windows 32 bit

Is your instant client packaged such that you simply extract it into a folder, add that folder to PATH, and setup the TNS_ADMIN variable or is this the one that you setup by running the supplied .bat file and it
creates registry entries for you? If the latter, I think you’re out of luck as that support was added for Toad 12, possibly Toad 11.6, but no earlier. I don’t have the 12 instant client yet, but I plan on grabbing it soon.

Michael

On 07/16/2013 02:53 PM, kushal.mahajan wrote:

Trouble configuring Toad for oracle 9.7.2 commercial with instant client

Thread created by kushal.mahajan
I have succesfully setup the instant client with sqlplus connecting to database correctly. Now on starting Toad 9.7.2 commercial My service name as specified in the tnsnames.ora does shows up under database but there is no instant client showing there .
Earlier i had ran TOAD 12 TRIAL and it it worked with the same instant client nicely .

what is wrong with this previous version of toad .

PLATFORM -MS WIN7 64 bit

INSTANT CLIENT basic and sqlplus Version 12.1.0.1.0 for windows 32 bit

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Well, I’m having trouble with the instant client on Toad 12.1 beta so you’re not alone. Also, remember that you’re using a very old version of Toad with the latest version of the Oracle client. You shouldn’t expect any support of it at all in Toad 9.7. I’d
grab an older client.

On 07/16/2013 02:53 PM, kushal.mahajan wrote:

Trouble configuring Toad for oracle 9.7.2 commercial with instant client

Thread created by kushal.mahajan
I have succesfully setup the instant client with sqlplus connecting to database correctly. Now on starting Toad 9.7.2 commercial My service name as specified in the tnsnames.ora does shows up under database but there is no instant client showing there .
Earlier i had ran TOAD 12 TRIAL and it it worked with the same instant client nicely .

what is wrong with this previous version of toad .

PLATFORM -MS WIN7 64 bit

INSTANT CLIENT basic and sqlplus Version 12.1.0.1.0 for windows 32 bit

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

well i installed a 10.1 instant client and it does resolved the problem .

But on connecting i got a ORA 12514 error now.

You have a configuration issue. We have work in this area scheduled for Toad 12.1 to assist in resolving these issues.

On Login window, click the TNSNames Editor button. Verify that the host for the TNS names entry you’re using is correct. Can you ping that host? In the TNSNames Editor you should also try to tnsping the database. See the lightning bolt icon on the toolbar.
Also, can you connect with SQL*Plus using that same client?

On 07/17/2013 02:52 PM, kushal.mahajan wrote:

RE: Trouble configuring Toad for oracle 9.7.2 commercial with
instant client

Reply by kushal.mahajan
well i installed a 10.1 instant client and it does resolved the problem .

But on connecting i got a ORA 12514 error now.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


From: bounce-kushalmahajan@toadworld.com
To: toadoracle@toadworld.com
Subject: RE: [Toad for Oracle - Discussion Forum] Trouble configuring Toad for oracle 9.7.2 commercial with instant client
Date: Wed, 17 Jul 2013 18:52:36 +0000

RE: Trouble configuring Toad for oracle 9.7.2 commercial with instant client

Reply by kushal.mahajan
well i installed a 10.1 instant client and it does resolved the problem .
But on connecting i got a ORA 12514 error now.

To reply, please reply-all to this email.

Stop receiving emails on this subject.
Or Unsubscribe from Toad for Oracle - General notifications altogether.
Toad for Oracle - Discussion Forum

Flag this post as spam/abuse.

Yes, i did that with cmd . Pinged and saw two service names which were listed by listener . These are CLRExecProc and PLSExecProc if i am remembering it corrrectly .AFter editing my tnsnames.ora file with service name listed by listener and On hitting connect button i got a net8 admin error this time . Tried logon option of oracleservicesXE under services.msc . AFter restarting too , not able to see the results .

Regards,
Kushal Vedant Mahajan


From: bounce-mstaszew@toadworld.com
To: toadoracle@toadworld.com
Subject: Re: [Toad for Oracle - Discussion Forum] Trouble configuring Toad for oracle 9.7.2 commercial with instant client
Date: Wed, 17 Jul 2013 19:11:35 +0000

Re: Trouble configuring Toad for oracle 9.7.2 commercial with instant client

Reply by Michael Staszewski
You have a configuration issue. We have work in this area scheduled for Toad 12.1 to assist in resolving these issues.

On Login window, click the TNSNames Editor button. Verify that the host for the TNS names entry you’re using is correct. Can you ping that host? In the TNSNames Editor you should also try to tnsping the database. See the lightning bolt icon on the toolbar.
Also, can you connect with SQL*Plus using that same client?

On 07/17/2013 02:52 PM, kushal.mahajan wrote:

RE: Trouble configuring Toad for oracle 9.7.2 commercial with
instant client

Reply by kushal.mahajan
well i installed a 10.1 instant client and it does resolved the problem .

But on connecting i got a ORA 12514 error now.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or Unsubscribe from Toad for Oracle - General notifications altogether.

Toad for Oracle - Discussion Forum

Flag this post as spam/abuse.