Unable to generate script for ....

Just downloaded Toad Edge, connected to instance of MySQL db. My issue is when I double click on a procedure or a function within the Object Explorer I am unable to edit/modify this? I get the comment under the script tab “-- Unable to generate script for […]”

Are the procedure/functions without an error? Right-click and make a selection.

The stored procedure don't seem to have any errors, if I double click on the procedure it opens in a new tab, but under the source tab within that procedures tab I get "unable to generate script for SP_... and if I click on the SQL button I get the same message. I don't understand why this doesn't allow me to open and edit the script? Is this not the correct why to do this? Is this because I am on a trial version?


this kind of issue is a bug on application part. It should be resolved with version 2.0 that is going to be released soon.

Is there any workaround for this issue in the meantime?

I am afraid that there is no way around that for now.

I am facing this too.
Connecting to the MySQL 14.12 Distrib 5.0.51a, for debian-linux-gnu.
And I have tried Toad Edge 1.2 and Toad Edge 2.1.1 with the same error message, so version 2.0 seems not to resolve this at all.
Too sad :frowning:

UPD 20 mins later:
Downloaded old and monstrous Toad for MySQL freeware v2.0.2.604 and it works perfectly!