Toad World® Forums

unknown command "edit" - rest of line ignored.

I get “unknown command “edit” - rest of line ignored.”

The syntax I use is very simple

EDIT tablename;

I also tried

EDIT tablename

without the semicolon.

Neither worked. They did in the past. Any ideas on fixing this? Thanks

I’m using Toad 10.1.1.8 but the EDIT command has stopped working for some reason.

EDIT was a Toad specific command that was deprecated and removed from the product several years ago.

You must be trying to run the edit command ‘as a script’, which you cannot do. It has always worked for me, through version 10 and still does now in 11.6 but you must run it as a statement or snippet.

Other than that, there have been two glitches introduced with it since about 10.1 or 10.5 (I can’t remember exactly):

  1. It is finicky about where lines are split; it won’t work if you have a newline within an ‘IN’ clause; i.e the following doesn’t work

edit customer_tab where cust_id IN (100,
200,
205)

whereas this works:

edit customer_tab where cust_id IN (100,200,205)

  1. The ‘alter session set current_schema’ command doesn’t quite work in concert with the edit command anymore, such that when you are not logged in as the schema owner you still have to provide the schema name with the table WHEN YOU EDIT, even though you don’t have to for anything else. So if I’m logged in as my self and the schema owner is SCOTT you can do the following:

alter session set current_schema = ‘SCOTT’;

select * from DEPARTMENT; --don’t have to do SCOTT.DEPARTMENT

but if you want to update the table, and do

edit DEPARTMENT

it will return data to the grid, but once you change it, it will complain that it can’t find the table (in your schema) and therefore instead you have to use

edit SCOTT.DEPARTMENT

which then works.