Toad World® Forums

Using Kerberos with Toad

I need to setup Toad to use Kerberos. I have installed Kerberos and can connect to an Oracle database using SQLPlus /@dbname . However, when I try to connect to the same database from Toad using blank username/password or EXTERNAL and blank password, TOAD throws ORA-12641: Authentication service failed to initialize error. I have searched the forums and Internet for answers. I cannot use OPS$. Any suggestions?

I’ve never been equipped to test it personally, but I’ve been told that others have gotten it to work with EXTERNAL. Are you sure that Toad and SQL*Plus are using the same Oracle client?

It is. I only have one Oracle Home on the laptop. I have tried using EXTERNAL with blank password and blank username with blank password. I get the same error either way.

I agree, EXTERNAL does not work and results in a “Password not specified” error, which is technically correct but useless for this exercise. [;)]

This is with 12.10.0.30.

Bryan

Are you trying to do a proxy login with Kerberos? If so, the proxied username needs be in brackets after EXTERNAL. So, EXTERNAL[PROXIED_USERNAME]

See this thread http://www.toadworld.com/products/toad-for-oracle/f/10/p/27384/58737#58737

(in that thread, we had a schema named B as an example, but whenever we enclosed B with brackets, the forum turned that into a beer. So when you see beer, it’s [ B ] (without the spaces)