Toad World® Forums

v30.0.0.80 - Access violation in module 'QP5CA.dll'


#1

While editing a package, the following error was thrown:

Access violation at address 00000000240D32F8 in module ‘QP5CA.dll’. Read of address FFFFFFFF817E92A8

This has occurred 3 times so far, and any attempt to use TOAD (specifically compile the package) after the error has occurred, causes TOAD to lock up.

When using TOAD, I generally have multiple connections (4 or so) open with at least that many editors open, each with a handful of packages. I also generally have multiple instances of TOAD open, but believe that I ran into this issue with only 1 open. (This last time I had 2 open) I have not seen this error with previous version TOAD.

Thanks,

David


#2

This very same issue (same addresses) was also signaled earlier by Peter Lang. I’ll make sure to look at this next week.

Thanks,
Andre


#3

Good news, I recreated the issue with a more simplistic data case. With only one connection open and one package open, I described a package from another schema, then proceeded on making small changes to the package. The ERROR was generated while editing the code, not even while attempting to compile.

David


#4

Okay, I’ll install a 64 bit and I’ll start playing (editing) with it. Feel free to post anything particular that may trigger the error. :slight_smile:

Thanks,
Andre


#5

I identified and fixed a 64 bit porting issue. The fix will show up in QP5 version 5.330, in the beta somewhere as of next week.

Thanks,
Andre


#6

I am getting error “TOAD Access violation at address 00000000240D32F8 in module ‘QP5CA.dll’. Read of address FFFFFFFF80BE92A8” while editing SQL in TOAD Editor using 64-bit TOAD 13.0.0.80 with QP5CA version 5.325.18075.15411. Where can I get 5.330 version of this DLL?


#7

Hello Boris,

QP5 and QP5CA DLLs version 5.330 showed up in Toad version 13.1.0.13 of May 31, 2018.
So this version and any more recent versions should be fine.

Hope this helps,
Andre