Toad World® Forums

Version 5.0 issues. Notably Setup is lost after closing

#1

Waited as long as I could after upgrading to see if anyone else had same issues.

Main issue is all of my pinned "managers" are gone after app is closed and reopened. I'm quite sure they were returning up until I opened Toad via the "Toad Workbook" shortcut. Ever since I did that now TDP opens with a workbook window on the left and no pinned managers. ( Why am I being forced to have Workbook open (or pinned) at all times? I can't find a way to disable Workbook. )

2nd issue is, double clicking any file types associated with TDP does nothing. Even if I right click the file (say *.sql) and choose OPEN WITH TDP, TPD does not respond. I do get an hourglass for a second or so. I checked my windows associations and they are all mapped to TDP as desired.

Not concerned with this one as using the DSN still works.

per the release documentation I tried setting up a new PostGres connection and unchecking "use data source name". After entering values and hitting connect I get this error -
"FATAL: database "ckasisch" does not exist"
, yet "ckasisch" is what I have under "USER".

thanks for any help.

#2

RE: Layouts: It is true that when you use workbook we force the layout. We have an enhancement to allow retention of user session layout in the future. We did this so that the concept of workbook would be easily understood. It is quite different as the data in the windows flow together. In regular TDP the modules are all independent as well as the docked windows.

Do you want to use TDP or Toad Workbook? If you want to use TDP and save layouts, go to your Help | About | app data dir and rename it. Then start up TDP regular and say "Yes" to migrate your settings from previous versions.

RE: File associations. Go to Options|Extensions. Select the file extensions you want to associate to TDP and press apply. We will need to elevate your privileges to make this change.

RE: Postgres connection. This works for me. Does your connection look like below? You can also leave out the database and it should also work.

#3

Thanks.

Your fix for the layout worked. I had thought Workbook was going to be treated similarly to Automation, in that "Tools / Automation...". To use it ad hoc. I'll go back and watch the videos etc when I can but will have to have a full understanding before i launch it again if it's going to change the way I use TDP day to day.

Re: PostGres connection. It works now. Chalk this one up to user error.

I still cannot get extensions/associations to work. Before posting I checked the extension set up in both TDP and Windows and all are linked. Thinking it a Windows issue, I did a uninstall/reinstall but to no effect. The reinstall picked up all of my 5.0 settings so "feels" like the uninstall was cosmetic.

I can live with opening files via the GUI, but if you have any additional thoughts please advise. I may try changing one or more to a nonTDP app via Windows and then changing back. thanks again.

#4

I think that once you have manually set an extension with the operating system, that applications can no longer programmaticly set them.