Toad World® Forums

SQL Editor Issue

Hi,
I’m using Toad 11. I type a SQL statement in an editor window and run it and all is fine. Now I want to save the statement to use later. After I save it the editor window is now “Disabled”. I can no longer edit the statement or anything. This seems to be happening will all statements I type. After I save I can no longer make changes to them. After saving the word “Disabled” appears in the status bar at the bottom of the screen. What can I do to correct this?

Hi Scott,

Is Team Coding enabled on your database? What do you see when you go to
Utilities > Team Coding > Team coding status?
image001.jpeg

Well it looks like it is enabled. But I don’t see what that has to do with being able to edit a sql statement that only exists on my hard drive. It’s my statement. I wrote it and I’m the only one who executes it. What does team coding have to do with that? I’m not trying to be harsh. I’ve never used or even looked at team coding in Toad so I’m not really sure what it’s all about. I just don’t see how, or why, these things are related.

Can someone explain why having Team Coding enabled in the database would prevent me from running a saved SQL statement that is saved ONLY on my machine?

Maybe your SQL statement includes DDL for a controlled object? You will have to
access Team Coding configuration to see which DB objects are being controlled.
Go to Utilities > Team Coding > Team coding code collections to see this.
image001.jpeg

I run and save “select sysdate from dual” and it then becomes “Disabled” so I’m not sure which objects could be included.

Attached is what I see regarding Team Coding.
TC.gif

What if you save to a different directory on your machine?

Is general source control setup? Options > Source control

At this point, it could be a number of things and I highly suggest going to
Quest Support with this issue. they are better equipped for these kinds of
things.
image001.jpeg

What if you save to a different directory on your machine?

Is general source control setup? Options > Source control

At this point, it could be a number of things and I highly suggest going to
Quest Support with this issue. they are better equipped for these kinds of
things.
~WRD000.jpeg

Scott,

I agree with Brad. The fact the menu items for Check in, check out etc are all
disabled suggests that the active object in the editor is not controlled by team
coding. If it were locked by Team Coding the Check Out and Get Latest options
would be enabled. Something else may be going on. I would also like to see the
value(s) of Code Collection File Masks in Utilties-Team Coding-Team Coding code
collections.

Stephen
~WRD000.jpeg

That’s kind of the point; I’m not using team coding. Nothing has been checked out, nothing has been checked in, and I’m not trying to check anything in. Also, I do not see the option either of you refer too; “Team Coding Collections”. All I have access too is what you see in the screen shot I provided.

I do not think that Team Coding is the cause of this issue. I think this is one
for Quest Support

Perhaps it’s file system related. Something at the file system level is
registering as having the file open (triggering the read-only). If the file is
marked read only when you open it, from what I recall of the behavior of Toad,
it will be greyed out.

The underlying Windows system registers when something has been opened and
sometimes it won’t let you do anything with the file while it is opened by
the other software. From what I’ve observed, it’s certainly not
consistent in its behavior. From recollection it’s been quite some time
since I even ran into the situation. I do recall that it wasn’t Toad I ran
into it with… but I can’t recall any of the specific circumstances
where it’s occurred.

Additionally, attempts to “recreate” the issue are all failing.

Roger S.

Scott,

I gave you some wrong information in an earlier reply. If you are using 10.6 or
lower then the Team Coding information would be in Utilities – Team Coding

  • Code Control Groups. We changed the Terminology in Toad 11.

Could Team Coding be enabled from a prior installation ?

First, can you check your support bundle in Help-Support Bundle you can copy or
email. This will give information on whether Team Coding is enabled and which
version.

Stephen

From Support Bundle:


TEAM CODING


TEAM CODING STATUS FOR CONNECTION [xxxxxx]
Team Coding Version : 6.0
Enable Team Coding : True
Use Code Collections : True
Use 3rd Party Version Control : True
Mirror Schemas : True
Apply Team Coding to all Objects : False
Update Database After Check-In : False
Force Comment During Check-In : False
Script File Extensions : *.sql;
Provider Name : SVN
Provider Initialized : True
Provider Connected : False
Message log :
8:54:01 AM: Team Coding Objects found in schema TOAD
8:54:01 AM: Detected Team Coding Support version 6.0, installed by TOAD
The Team Coding Support on this database is an older version which is not compatible with this release of TOAD. To enable Team Coding, the Team Coding Support Objects must be updated using the Team Coding Configuration Installer. This task should be performed by a database administrator.

8:54:02 AM: Provider initialized:

Scott ,

There are several issues here.

The menu items in your menu are from 10.6 but the Toad Bundle is using the
terminology from Toad 11. First confirm that you are running Toad 11
(overstating the obvious but you never know). It is possible your tool bars did
not update when you did the upgrade to Toad 11.

Right click on your main Toolbar click ‘Restore Defaults’ also make
sure the ‘Team Coding’ toolbar is checked in this menu. This is just
until we can figure out what is going on.

The utility menu should now look like this

It looks like the version of Team Coding is not correct for Toad 11. You should
be able to select Configure Team Coding. This may be ‘read only’ if
you are not a Team Coding Administrator. You should get a message to tell you
that Team Coding requires an upgrade. A Team Coding administrator or DBA user
needs to do this.

If you want to disable Team Coding, you must be a Team Coding Administrator to
disable or uninstall Team Coding, in the Configure Team Coding Menu.

Team Coding Code Collections should be enabled. You should be able to display
the collections and the File Mask values. If any line shows something like .
this could be the issue. A Team Coding Administrator can modify this mask.

Let’s see if any of this helps.

Stephen
image001.png

I am using version 11.0.0.116.

I performed the Restore Defaults action and my Utilities -> Team Coding menu now looks like yours. I clicked “Configure Team Coding” option and I’m told that “Team Coding install is invalid. Team Coding is disabled.”. The configuration dialog is displayed but all items are grayed out (disabled). The support bundle tells me that the version installed in the database is not compatible with version 11.

I just want to be able to save a query I wrote and then execute it at some other point. I’m not participating in team coding, just running a query.

If Team Coding is enabled it is enable for all users, there is no opt out. You
are probably disabled because the upgrade is required and Team Coding is enabled
for that Database … I probably need to look at how this is handled in 11.1
at least for saving files locally as uncontrolled objects.

The best option is to run the Team Coding upgrade. Second best is to disable
Team Coding.

Stephen

One thing I did notice. As a “habit” I save my SQL statements with a “.sql” extension. I noticed that my statements are only disabled when they have a file extension of “.sql”. If I save them with “.duh” or whatever I can run them. What controls this? In the TOAD schema of the database I see 2 tables, TC_CONFIG and TC_MASK, that contain references to “*.sql” files. Would this be causing problems with saving .sql files locally?

We are using an Oracle 10g database with TOAD 11 and Team Coding installed along
with Subversion. Currently, we have three developers who make changes to
database objects and now must check out / in those objects. When it comes time
to release these changes to QA or production, what is the best way to find the
changes so a script can be prepared? Are there any built in tools for scripting
all the changes?

Best Regards

Timothy Bryan

We are what we repeatedly do. Excellence, therefore, is not an act but a habbit.

Aristotle

Hello,

Team Coding does not have a specific function to do this. But you might want to
check out the Schema Browser ‘Create Script ‘ option and also
Database Export options which may be able to accomplish what you need.

Stephen