Toad World® Forums

11.5 Team Coding: SVN: Cannot use Repository Prefix

Hello,

I really need to get Team Coding / SVN working with Toad, but our SVN server uses a prefix prior to the repository list (as is a best practice). This means that to connect to the SVN server, you must enter the following URL:
http://servername:8082/svn
There is no way to account for this prefix in Toad, however. I have to enter the server and the port separately, which seems like an inflexible way to handle this.

Is there a way around this?

Thanks!

–Zach

2012-07-17_1045.png

Okay, when I look at the Team Coding config in the database I see some interesting stuff. The WebDAV server and port are separate:

WebDAVServer=XXX.XXX.XXX.XXX\r\nWebDAVPort=8082

But it also stores a log-in, with another config:

[LOGIN_1]\r\nRepository=http://XXXX:8082/svn/sql

Which setting is being used when I log in? My main problem is that nothing is showing up in the SVN browser, and I cannot create new collections because there are no VCS Projects listed.

Anyone that can assist here?

An infinite advance on thanks!

–Zach

Message was edited by: Zachary

Hi, more information and loving the log file:

Here is the request that Toad is running:

“D:\csvn\Subversion Client\svn.exe” list --username **** --password **** http:///XXX.XXX.X.X:8082/svn/sql/

Here is the response:

Unable to connect to a repository at URL ‘http:///XXX.XXX.X.X:8082/svn/sql’

The request has 3 forward slashes in the URL. If I run the request in the command line, I get the same result. Removing 1 slash gets me the list.

How can I fix this?

Thanks,

Zach

For people in the future world needing, also, a solution:

You can specify the full URL in the server box (sans the http://), but make sure to leave the port at the default port 80.

It looks ugly in the verification message (SVN Server box attached), but if you then only supply the repository path in the subsequent connection requests (for me it is svn/repo_name) the little guy will connect.

Hope this one helps.

–Zach
2012-07-17_1243.png