Toad World® Forums

Cannot connect to svn in TeamCoding

Connecting to a svn-repository leads to:

** SVN Output **

svn: E170013: Unable to connect to a repository at URL ‘svn+ssh://dev.oracle.ot1.ch/svn/oracle’

svn: E210002: To better debug SSH connection problems, remove the -q option from ‘ssh’ in the [tunnels] section of your Subversion configuration file.

svn: E210002: Network connection closed unexpectedly

With putty and with oracle’s SQL-Developer I have no problem reaching or connecting to the same svn-Repository.

TortoiseSvn 1.9.4 is installed on the machine.

Any idea what I am missing?

Thanks for your Helo

Stefan

Hi Stefan,

Have you tried turning on VCS Debug Logging and VCS Command Output in your Team Coding Options? That might give you some further information on why Toad seems to be having trouble connecting to the remote repository. It sounds like something might not be configured correctly within Toad.

Did this issue just start, or has this been an issue for a while? Which Toad version are you using? Are you able to connect using a previous Toad version?

-John

Hi John

thanks for the answer.

I have the latest Toad 12.9. It did not work neither with 12.8.

And I have never connected to svn before from toad on this machine.

Debug-Logging did not give more information.

Althought I gave a username / password in the connect request form, a TortoisePlink window asking for username and password pops up.

Regards

Stefan

**
Stefan Berner**

Dipl. Ing. ETH

Senior Expert


Diso AG

Dienstleistungen und Software

Morgenstrasse 1

3073 Gümligen

Switzerland

Phone: +41 31 958 90 90

Mobile: +41 79 474 71 41

Fax: +41 31 958 90 99

Am 27.06.2016 um 15:35 schrieb John Bowman bounce-jbowman@toadworld.com:

RE: Cannot connect to svn in TeamCoding

Reply by John Bowman
Hi Stefan,

Have you tried turning on VCS Debug Logging and VCS Command Output in your Team Coding Options? That might give you some further information on why Toad seems to be having trouble connecting to the remote repository. It sounds like something might not be configured correctly within Toad.

Did this issue just start, or has this been an issue for a while? Which Toad version are you using? Are you able to connect using a previous Toad version?

-John

To reply, please reply-all to this email.

Stop receiving emails on this subject.
Or Unsubscribe from Toad for Oracle - General Forum notifications altogether.
Toad for Oracle - Discussion Forum

Flag this post as spam/abuse.

Hey Stefan,

I did some testing over the past couple of days and was able to reproduce the issue you're seeing. SVN+SSH is a different kind of animal in that all of the authentication happens within SSH, rather than within the Subversion client. As a result, the commands issued by Toad need to be formatted differently than standard Toad/SVN connections.

I can try to fix this in the next beta that will be starting up here soon. In the meanwhile, as a workaround, I would recommend adding the username to your Repository URL connection string when creating your connection, and leaving the password field blank. You'll also need to add "%40" (the URL encoded value for '@') between the username and server, otherwise SVN may interpret the server name as a revision specifier and return a different error.

Here's an example of what I'm using in my testing locally:

For SSH connections, make sure you have your local TortoisePlink settings correctly mapped to your private key, and that your public key is correctly installed on the server. The fact that it asked you for your password suggests that something may not be linking properly through TortoisePlink.

One word of caution I've noticed in my local testing: SSH is fairly finicky in its connection. If the command is formatted incorrectly, or perhaps if it has a missing or invalid username in the connection string, the whole command-line can appear to freeze. That seems to be a result of the connection failing to complete an SSH tunnel, Unfortunately, that may cause Toad to freeze as well as it's waiting for a response from the server, and in these cases, the server never returns a response. In my research, I found there are a number of articles online that recommend against using SSH and talk about alternative ways to encrypt a connection to Subversion through its own svnserve daemon (mostly using SASL). If you have the flexibility, it might be worth looking into that as an alternative as it seems to be quite a bit more straight-forward in its configuration.

Either way, I hope this helps in getting you set up within Toad 12.9. As soon as I have a permanent fix in place for the 12.10 beta, I'll post another response here to let you know.

-John

Btw, here’s a link to the Subversion documentation that talks about configuring svnserve with SASL:

svnbook.red-bean.com/…/svn.serverconfig.svnserve.html

Hi John

Thanks for the answer.

I did not succeed. But I think it has something to do with TortoisePlink, as my Tortoise in windows explorer has a similar problem.

I will try to fix this problem after my holidays. For the next 4 weeks, I will be absent.

Regards

Stefan

PS: I accidentely deleted your last email (and emptied the wastebasked) Could you please resend the last eMail? The one with the explanation about TortoisePlink.

**
Stefan Berner**

Dipl. Ing. ETH

Senior Expert


Diso AG

Dienstleistungen und Software

Morgenstrasse 1

3073 Gümligen

Switzerland

Phone: +41 31 958 90 90

Mobile: +41 79 474 71 41

Fax: +41 31 958 90 99

Am 27.06.2016 um 15:35 schrieb John Bowman bounce-jbowman@toadworld.com:

RE: Cannot connect to svn in TeamCoding

Reply by John Bowman
Hi Stefan,

Have you tried turning on VCS Debug Logging and VCS Command Output in your Team Coding Options? That might give you some further information on why Toad seems to be having trouble connecting to the remote repository. It sounds like something might not be configured correctly within Toad.

Did this issue just start, or has this been an issue for a while? Which Toad version are you using? Are you able to connect using a previous Toad version?

-John

To reply, please reply-all to this email.

Stop receiving emails on this subject.
Or Unsubscribe from Toad for Oracle - General Forum notifications altogether.
Toad for Oracle - Discussion Forum

Flag this post as spam/abuse.

Hi Stefan,

If you click the heading of the thread in your email, it takes you to Toadworld.com where the entire thread can be seen, and replied to in your Web Browser.

HTH

Cheers,

Norm. [ TeamT ]

Sent from my Android device with K-9 Mail. Please excuse my brevity.

Hey Stefan,

SVN+SSH connections should be fixed in Monday’s beta version of Toad. You’ll need to make sure that you can connect to the server using your private key and the plink tool. You can test it with the following command:

plink -i

After this, you’ll need to make sure the private key is added to your Subversion config file, which is located in %APPDATA%\Subversion\config. You can do this by adding the following line to the [tunnels] section of the file:

ssh = -i

You may need to escape any backslashes in the path if you use them instead of forward-slashes.

For further information, check out the following link: http://agateau.com/2007/windows-svnssh-and-the-subversion-command-line-client/. This setup should work for Toad 12.10 beta and Toad 12.10 GA when it’s released.

-John