Toad World® Forums

12.6 tnsnames.ora

Hi,

Myself and the other experienced coworker (who works remote) are on a very old version of TOAD. Our new person has 12.6. I got his tnsnames editor button in the sessions pop up to work, but can’t get the sqlnet editor to work.

I don’t know who set it up. I was able to get the TNSNames Editor click button in the Sessions box to open. The problem is I can’t find a sqlnet.ora file to changes the names.directory_path to his local tnsnames.ora file. We did a search, found the oracle directory (which is not the same as ours) but no sqlnet.ora file.

Any ideas? I’m thinking part of the problem is that we have our Oracle 11g client installed right under the C drive. I think there are also permissions issues as he appears to have to type in an admin userid to his stuff and its located on the c drive. We dont have to use an admin password for that. The new coworker does.

Thanks for any comments.

Vic

The problem is I can’t find a sqlnet.ora file

It may not exist as it is not required. It would live alongside your tnsnames.ora file. Since you can’t locate one just create one in the same folder as your tnsnames.ora and set the values within as you need.

Michael

Hi,

Thanks. I took a copy of mine, and deleted everything out but the tnsnames.ora file and he changed it to his location, which is in the same directory as the tnsnames.ora file. Closed out TOAD and got it back up but the sqlnet.ora file is still greyed out.

The button is only disabled if the sqlnet.ora file does not exist in the location expected. Double-triple check the file’s location. Refer to Oracle’s documentation regarding the search order for the files (section 5.1) https://docs.oracle.com/cd/B19306_01/server.102/b15658/cnfg_net_srv.htm#UNXAR213. Also, click the ‘…’ button beside the selected client on the login window. Post a screenshot of what you see in there.

Michael