Toad World® Forums

13.2.0.18: Access violation in EurekaLog's user event handler


#1

This happened when closing a describe window using Escape.

image

Followed by

image


#2

I tried to reproduce this but could not.

Is this 32 or 64 bit Toad?
Does it happen every time?
Does it matter which object type you describe?
Did you have any errors in Toad before that?


#3

64 bit. This has only happened once, I don’t think that I had any errors before.


#4

I just got the same error, followed by a different AV:

image


#5

Thanks Peter. Unfortunately, I can’t do anything with those addresses.

32 bit Eurekalog has had a better track record than 64. We might get the actual error if you can switch to 32 bit Toad for a while. If not, you can email me your user files folder and I’ll run with your options and maybe I’ll get the error too. Send it to john.dorlon@quest.com.

Thanks.


#6

I have been emailing Peter offline, but Incase anyone is following this…

I was able to reproduce an AV this way:

  1. Open a describe window
  2. go to the Script tab
  3. before the script is shown, hit ESC to close the dialog.
  4. AV is shown.

This should be fixed in the next beta. If any AV persists, please let me know.