[16.2.34] Passwords for DB connections must be entered when restoring a workspace at program startup

If a workspace is loaded at program launch (option "Automatically save and restore workspace" enabled), it is required to enter a password for each DB connection, even if the passwords for the connections are saved.

I just tried to reproduce this but for me it is working fine. This is what I did. Let me know if I missed anything. Also, which beta were you on before 16.2.34 (assuming the only thing you changed when it just started happening was update your beta)

  • Opened 4 connections.
  • Opened windows for some of the connections
  • opened an Automation Designer
  • created a workspace for them
  • Turned on the auto load/save workspace option
  • Closed Toad and restarted - no prompts.

Oops, it looks like I somehow disabled the "Save passwords" checkbox in the connection dialog.
It looks like the passwords for the affected connections are not saved at the moment.

It now works as intended. Sorry for the fuss.

1 Like

I'm not a fan of "are you sure" dialogs, but maybe one there would be warranted since it's going to forget all your passwords if you uncheck it.

I think that's a good idea. I had this problem in the past, when I accidentally deleted the passwords for > 100 connections. That was a lot of work to save them again :wink: