Toad World® Forums

6.2 - double click on datagrid


#1

In 6.1 doubleclick on any value on datagrid (select results) used to open popup window with multi-line editor/viewer for this column. Was usefull for long strings. In 6.2 it’s no longer the case, at least with default preferences. Any way to bring this behavior back ?


#2

I’m not sure if I use any non-default preferences, but the cell editor pops up just as it did before whenever I double-click on the any result cells.


#3

Yes, it should be there just like 6.1. Does this happen with any specific datatype? Could you please provide a screenshot?

Thanks
Gwen


#4

Hi,

Same issue here. Release 6.2 on Windows XP SP3, Editor for CLOB and XML Type won’t show. I allready gave it to Quest Support, Case Number 744100, if you need more information on this case. Latest Beta Release and all older Beta worked fine.

Ulrich


#5

Hi Ulrich,

We’re investigating this case. I will keep you posted.

Gwen


#6

Hi Ulrich,

I’m now looking at this case. Could you provide information of following questions?

  1. Did you install SQL Navigator release 6.2 into a new folder or into a folder where previous beta/release installed?
  2. You mentioned that you uninstalled all the SQL Navigator then reinstalled 6.2 again but it still doesn’t work. Did you delete the folders where previous SQL Navigators were installed before you started to restall 6.2?

You mentioned that You (newly?)installed 6.2 into another system and it worked correctly there. So I want to make sure that, with the system where 6.2 doesn’t work, you install 6.2 into a clean place and all the files in the 6.2 folder are coming from the same installation. What I consider here is the data_editors.dll in C:\Program Files\Quest Software\SQL Navigator 6.2\ folder has be the correct file. If it’s correct, it should have properties identical to those in the sreenshot that I attach.

Thanks,
Vincent
data_editors.dll.jpeg


#7

Hi Vincent

I checked the mentioned DLL and found no difference

Yes, i did a fresh install (on a fresh installed System, no old vesions of anything ) and there it’s working fine. I also checked the Properties of the DLL on the working System and its identitcal to the no-working System.

Thank you

Message was edited by: ulrichvaid

Message was edited by: ulrichvaid


#8

Thank you for the information Ulrich. Now I know it’s not a problem with files from previous installation. This time I want to eliminate the possibility that the issue may come from the settings and user data of previous version/beta build of SQL Nav. Can you please try clearer steps to reinstall 6.2 in your no-working system?

  1. uninstall 6.2 using Quest Installer(find in the Quest Software group in Start menu);
  2. remove the folder where 6.2 was installed;
  3. remove folder C:\Documents and Settings<username>\Application Data\Quest Software\SQL Navigator 6.2.0;
  4. remove regestry node HKEY_CURRENT_USER\Software\Quest Software\SQL Navigator 6.2.0;
  5. install 6.2;
  6. start 6.2; – if it prompts Import User Profile Settings, click Cancel;
  7. now try to use SQL Nav 6.2 to see if the problem is there.

This is what we call a clean reinstall. Please let me know how you go this time.

Thanks for all your feedback,
Vincent


#9

Hello Vliu,

Thank you for your information. I followed your Instructions above to make a clean reinstall and now it’s working fine. So the Case can be closed. I would like to thank you and the team for the great support on this matter.

Ulrich

Message was edited by: ulrichvaid


#10

You’re very welcome Ulrich. Glad to know it’s working fine now:). We’re always happy to see that we can do something to make our users getting along well with SQL Nav. We really appreciate that our users provide feedback and respond to each other. That’s really help for making SQL Nav better.

Thanks,
Vincent


#11

Hi Mzgursky,

Could you please try the steps I mentioned in previous posts here to reinstall 6.2? I hope it will work for you too. Looking forward to your coming news.

Thanks,
Vincent