8.0 Editor - Highlighting Styles is not saving the selected colour

My v8.0 Editor - Highlighting Styles is not saving the selected colour for the display item 'Text' only. All others are okay. I want it white for the dark background but it changes back to black.
All Environment - Interface Skins seem to override the Highlighting Style

Hi Chris,

Thanks for raising this issue with us, our dev team is examining the issue at hand under the TSS-2163 item in our backlog, you may use this ID as a reference in case you collaborate with the support team as well on this one.

The dev team proposes a quick workaround solution: you may consider using different editor color background (preferably any light color) except black until the issue is resolved in our future releases.

Let me know how the workaround seems suitable for you,

This isn't an acceptable workaround.

Quest were proudly boasting 'Dark Mode'
Am I missing something?

Hi Chris,

It appears that we may not have been on the same page. The latest release of our product now includes the DevExpress Dark Style as the default dark theme. We have focused on optimizing this theme to provide the best user experience possible. If you use this theme, the problem you mentioned should not occur.

Please revisit the Options | Environment | Interface tab and set the DevExpress Dark Style as the theme of choice and let me know the results.

Hi Rejhan

This isn’t what I would call a dark theme. I currently use Office 2016 Black but obviously now in v8 the text is black.
DevExpress Dark Theme is a wishy-washy grey.

I guess I will have to wait for the bug fix…


Thanks for the answer Chris,

We will consider fixing the issue you reported with our next public release.

Has there been any update on this issue?

Sadly, no. It's a major flaw if you are looking for Dark Mode, as promoted in the new release....

Hello there, our roadmap for Toad for SQL Server 8.1 includes this item, and the fix will be available in our next release planned for Q2. Stay tuned