Toad World® Forums

Syntax Highlighting in 10.5


#1

I like to set my editor windows up with a dark background to save my eyes, as do many others. I’ve done this past versions of Toad with no trouble. However, I noticed the other day that in 10.5.1.3, when I set the PL/SQL syntax highlighting colors to go with my new background, certain characters are left black (and therefore unreadable).

These characters include these: !@%^&*|[]{}? In certain contexts, such as inside a string literal, they do show up properly.

I have two questions:

  1. Which item in the syntax highlighting list controls the characters in question?
  2. Is there an easy way to set Toad to use a dark editor theme without adjusting each item in the highlighting tab individually? I see that it’s possible to import/export these settings, but I haven’t found any themes available for download out on the web.

Thanks,
Todd


#2

You may have success by just changing the Editor’s font. This should
affect all items not covered by a syntax highlighting style. See the Fonts
groupbox in the Editor|Display page of Options.

There is no way to set an Editor theme nor is there a theme repository. Maybe
someone on this list will share their setting for a dark theme with you if there
are any out there using one.

Michael


#3

A couple of things I forgot to mention:

I checked an older version of Toad (9.7.2) that I had hanging around in my old WinXP VM, and noticed that the characters in question were controlled by the “Default” item in the list. That item does not appear for me in 10.5.1.3. Perhaps it has been moved elsewhere?

I did an export of my settings and opened up the file. I noticed that the “Default” item is listed in there, right at the top. I changed the color of that item from ‘clWindowText’ to ‘clWhite’ and reimported, but nothing happened. I then re-exported the settings to a new file, and here’s what I saw:

item
  DisplayName = 'Default'
  Font.Charset = DEFAULT_CHARSET
  Font.Color = clWindowText
  Font.Height = -13
  Font.Name = 'Consolas'
  Font.Style = []
  FormatType = ftCustomFont
end

It appears that two things are going on:

  1. The “Default” item is missing from the list in the Highlighting tab.
  2. Toad ignores the “Default” setting even when importing the settings from an external file.

#4

Michael,

Thanks for your suggestion. As it turns out, the color setting at Editor>Display>Editor… had gotten set to “Custom” (and I have no idea how). Setting the color to “White” took care of my problem.

I’m still a bit curious, though…does anyone know whether the removal of the “Default” item in the Highlighting tab was intentional or a bug?

Thanks,
Todd

Message was edited by: todd.boss_281


#5

How did you get all the whitespace characters to be black?